Bug 244544 - Deskjet 5440 Printer not showing up over Samba
Deskjet 5440 Printer not showing up over Samba
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Samba Maint Team
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-06-16 21:46 EDT by Ryan Helinski
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-12 14:50:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ryan Helinski 2007-06-16 21:46:50 EDT
Description of problem:
I have HP Deskjets 990C and 5440. Both used to work perfectly in FC5. Now, in
FC7, the Deskjet 5440 doesn't show up on Windows clients under the machine root
(like \\server\), but I can still print to the printer using CUPS. There was a
fluke extra printer which showed up previously in the cups-config-daemon
webpage, I installed it and it showed up in the document root, but upon retart,
only one printer for the 5440 was avaialable. I haven't really made any changes
to the default configuration, except the default driver was "Foomatic/hpijs" for
the Deskjet 540, which was wrong and I changed it to 5440, but the driver was
still Foomatic. Again, it works from Linux clients printing using IPP. The
system-config-printers shows both printers on other Fedora clients.

Version-Release number of selected component (if applicable):
Fedora 7, cups 1.2.10 - 10.fc7, samba 3.0.25a - 3.fc7

Additional info:

Please let me know what other additional information I can provide.
Comment 1 Ryan Helinski 2007-06-16 22:46:49 EDT
A printer, detected by the web CUPS daemon, called "5440" at
Device URI:
Seems to be forwarded (after a daemon restart) by Samba, whereas there is yet a
third driver detected by CUPS called 
Which is at Device URI: usb://HP/Deskjet%205400%20series?serial=TH5AH122KJ04K8
That does NOT show up over Samba.

As an intermediate solution, I'll try to keep just the "5440" driver and
"delete" the other printers. Also, the system-config-printer daemon was
complaining for me to submit a bug (id=244546) about the same printer.
Comment 2 Ryan Helinski 2007-06-16 22:50:16 EDT
I should have mentioned, the printer URI that is giving me trouble is:
Description: HP DeskJet 5400 Foomatic/hpijs
Location: Local
Make and Model: HP DeskJet 5440 Foomatic/hpijs (recommended)
Printer State: idle, accepting jobs, published.
Device URI: hp:/usb/Deskjet_5400_series?serial=TH5AH122KJ04K8

Sorry for the mess of comments.
Comment 3 Guenther Deschner 2007-06-18 09:30:26 EDT
I tried creating a local printer with the same name and it worked without problems.

Can you please provide log level 10 smbd logfiles?
Comment 4 Simo Sorce 2007-09-12 09:56:03 EDT
As there was no answer from the original poster I am going to close this as NOT
a bug.
Please reopen and provided the necessary details if the problem exists.
Comment 5 Ryan Helinski 2007-09-12 13:29:20 EDT
I had solved this problem some time ago, and I'm pretty sure I updated another
(related to foomatic) bug with this information. 

The problem was, without a doubt, that the name that CUPS chose to be the SMBD
name of the printer was too long or contained bad characters. It was something
similar to Deskjet_5400_series_serial_TH5AH122KJ04K8, and changing it to
DESKJET_5400 in the CUPS config file allowed it to show up over Samba. 

Please let me know how I can provide log level 10 smbd logfiles (none of the
Samba logs helped out when I was debugging this problem, but I didn't know what
I was looking for), or what else is necessary given the apparent solution. 

Note You need to log in before you can comment on or make changes to this bug.