Bug 244546 - Better model matching (5400 != 540C)
Better model matching (5400 != 540C)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-06-16 22:31 EDT by Ryan Helinski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.7.74.4-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 08:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output from system-config-printer (1.93 KB, text/plain)
2007-06-26 05:53 EDT, Ryan Helinski
no flags Details
lpinfo (2.87 KB, text/plain)
2007-06-26 08:47 EDT, Ryan Helinski
no flags Details
Listing of the /srv/devices virtual directory (80.95 KB, text/plain)
2007-08-17 14:57 EDT, Ryan Helinski
no flags Details
Actual files from the previous listing (16.62 KB, text/plain)
2007-08-17 14:58 EDT, Ryan Helinski
no flags Details
Output of `/usr/sbin/lpinfo -l -v` (2.89 KB, text/plain)
2007-09-25 14:40 EDT, Ryan Helinski
no flags Details

  None (edit)
Description Ryan Helinski 2007-06-16 22:31:04 EDT
Description of problem:
I just noticed this on my root terminal when running system-config-printer:


[root@gizmo ~]# Writing new pickle
Please report a bug in Bugzilla against 'foomatic':
  https://bugzilla.redhat.com/bugzilla
Include this complete message.
Guessing HP-DeskJet_540C from IEEE 1284 ID:
      <manufacturer>HP</manufacturer>
      <model>Deskjet 5400 series</model>
      <description>Deskjet 5400 series</description>
      <commandset></commandset>
URI: hp:/usb/Deskjet_5400_series?serial=TH5AH122KJ04K8

This may be related to a bug I've just posted id=244544.

Version-Release number of selected component (if applicable):

I think ,just plug in a Deskjet 5400 series (via USB).
Comment 1 Tim Waugh 2007-06-25 11:44:45 EDT
Please try the test update:

  yum --enablerepo=updates-testing update foomatic

Once the package is installed, is the correct printer model selected from the
list when you go to add a new queue?
Comment 2 Ryan Helinski 2007-06-26 05:53:12 EDT
Created attachment 157872 [details]
Console output from system-config-printer
Comment 3 Ryan Helinski 2007-06-26 05:57:40 EDT
In the system-config-printer tool, no. It's still choosing 540C as the model
after I delete both drivers for the Deskjet 5440 and go through the New Printer
process. The attachment 157872 [details] is the console output. I noticed that only one
5400 series driver is showing up in the list of New Printers.
Comment 4 Tim Waugh 2007-06-26 08:37:10 EDT
Please attach the output of '/usr/sbin/lpinfo -l -v'.  Thanks.
Comment 5 Ryan Helinski 2007-06-26 08:47:20 EDT
Created attachment 157889 [details]
lpinfo
Comment 6 Tim Waugh 2007-06-29 06:08:23 EDT
Thanks.  Now please show me the output of this command:

find /sys/devices -name ieee1284_id | xargs cat
Comment 7 Ryan Helinski 2007-06-30 11:58:32 EDT
That command returned nothing, so I did a 
find /sys/devices | grep ieee
And with grep 1284

Still nothing. I'll attach the full 'find' listing.
Comment 8 Tim Waugh 2007-08-09 08:42:55 EDT
Without that information I won't be able to fix this.
Comment 9 Ryan Helinski 2007-08-17 14:57:00 EDT
Created attachment 161760 [details]
Listing of the /srv/devices virtual directory

As requested
Comment 10 Ryan Helinski 2007-08-17 14:58:03 EDT
Created attachment 161761 [details]
Actual files from the previous listing

Passed file names to 'cat' as requested
Comment 11 Ryan Helinski 2007-08-17 15:00:05 EDT
I'm not sure of the current status of the bug as I haven't used the GUI recently
and received the error. I've been using the CUPS daemon remotely with a web
browser to configure the printer: I had a but with the same printer not working
on Samba because the default configured printer name was too long, and recently
the driver was switched to 'raw' rather than the HP Linux driver. Let me know
what other information I can provide, thanks. 
Comment 12 Tim Waugh 2007-09-25 12:28:28 EDT
Please show me the full output of this command, when the printer is connected
and switched on:

/usr/sbin/lpinfo -l -v
Comment 13 Ryan Helinski 2007-09-25 14:40:06 EDT
Created attachment 205881 [details]
Output of `/usr/sbin/lpinfo -l -v`
Comment 14 Tim Waugh 2007-09-26 06:06:22 EDT
Thanks.

The model matching algorithm in system-config-printer needs to be a lot smarter.
 The printer's model should be sorted in with the available models and the
before and after matches should be compared to see which is "better".  In this
case it would be between DeskJet 5160 and DeskJet 5440, with 5440 being "better"
(longer initial match).

Unfortunately, HP seems to have chosen to be inconsistent with the series name,
so we have 'DeskJet' (capital J) and 'Deskjet' (lowercase J), and this would
throw off the sorting.

So, I think we'll need to perform case insensitive sorting.
Comment 15 Tim Waugh 2007-09-26 07:26:19 EDT
Fixed in SVN for 0.7.74.x and trunk.  No package built yet.
Comment 16 Tim Waugh 2007-10-03 08:18:25 EDT
Fixed in 0.7.74.4.

Note You need to log in before you can comment on or make changes to this bug.