Bug 244564 - Segfault crash (on hardlink -H?)
Summary: Segfault crash (on hardlink -H?)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Simo Sorce
QA Contact:
URL:
Whiteboard:
Keywords: Patch
: 248663 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-17 12:05 UTC by Jan Kratochvil
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 2.6.9-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 21:16:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Untrusted but empirically verified quick fix. (467 bytes, patch)
2007-06-17 12:05 UTC, Jan Kratochvil
no flags Details | Diff

Description Jan Kratochvil 2007-06-17 12:05:35 UTC
Description of problem:
My regular backups started to crash on the remote side.

Version-Release number of selected component (if applicable):
rsync-2.6.9-2.fc6.i386 (crashing remote server side, F6.i386)
rsync-2.6.9-2.fc7.x86_64 (local client side, F7.x86_64)

How reproducible:
Always since 2007-06-05, IIRC since upgrading local F6.x86_64 to F7.x86_64.

Steps to Reproduce:
1. host0$ /usr/bin/rsync -aHAXrxS -e ssh --delete --stats / host1:/backup

Actual results:
local side hang
on --timeout: 
 io timeout after 900 seconds -- exiting
 rsync error: timeout in data send/receive (code 30) at io.c(165) [sender=2.6.9]
on remote side `ulimit -c unlimited' wrapper:
 /usr/local/bin/rsynccore: line 4:  6137 Segmentation fault      (core dumped)
 /usr/bin/rsync "$@"
 rsync: writefd_unbuffered failed to write 4 bytes [sender]: Broken pipe (32)
 rsync: connection unexpectedly closed (1598312 bytes received so far) [sender]
 rsync error: unexplained error (code 139) at io.c(453) [sender=2.6.9]

Expected results:
Successfully synced directory tree (45GB).

Additional info:
#0  0x004d76ac in free () from /lib/libc.so.6
#1  0x0806ef87 in rsync_acl_free (racl=0x5a6ff4) at acls.c:192
#2  0x0806f446 in free_acl (sxp=0xbfa48488) at acls.c:201
#3  0x08069a68 in hard_link_cluster (file=0xb727fe70, master=1155130,
itemizing=1, code=FLOG) at hlink.c:323
#4  0x0804ba7a in check_for_finished_hlinks (itemizing=1, code=FLOG) at
generator.c:611
#5  0x0804ef2e in generate_files (f_out=1, flist=0x8788a10, local_name=0x0) at
generator.c:1531
#6  0x080588f5 in do_recv (f_in=0, f_out=1, flist=0x8788a10, local_name=0x0) at
main.c:764
#7  0x080590e0 in start_server (f_in=0, f_out=1, argc=2, argv=0x87889e8) at
main.c:871
#8  0x0805998e in main (argc=2, argv=Cannot access memory at address 0x4
) at main.c:1378
#9  0x00483f2c in __libc_start_main () from /lib/libc.so.6
#10 0x0804a811 in _start ()

Core file not supplied due to the risk of private data exposure.

Attached patch file fixes the problem although it SHOULD be reviewed.
Unaware how it relates to the upstream rsync versions.
So far able to provide more reproducibility testing but the dataset may change.

Comment 1 Jan Kratochvil 2007-06-17 12:05:35 UTC
Created attachment 157219 [details]
Untrusted but empirically verified quick fix.

Comment 2 Jan Kratochvil 2007-06-23 13:45:07 UTC
It looks as fixed in upstream 3.0.0cvs for PREV_SX in FINISH_HARD_LINK there.


Comment 3 Simo Sorce 2007-08-10 17:46:52 UTC
*** Bug 248663 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2007-09-07 17:17:01 UTC
rsync-2.6.9-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2007-10-03 21:16:15 UTC
rsync-2.6.9-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.