Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 244570 - missing dependency to build kernel src.rpm
missing dependency to build kernel src.rpm
Status: CLOSED DUPLICATE of bug 240878
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 09:49 EDT by jasonn
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 10:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for spec file (320 bytes, patch)
2007-06-17 09:49 EDT, jasonn
no flags Details | Diff

  None (edit)
Description jasonn 2007-06-17 09:49:27 EDT
Description of problem:
When running 'make menuconfig' the command exits with error about missing curses.h.

Version-Release number of selected component (if applicable):
2.6.21-1.3228.fc7

How reproducible:
Ever

Steps to Reproduce:
1. Remove the package ncurses-devel if installed
2. Get the kernel src.rpm
3. Follow the instructions found in http://fedoraproject.org/wiki/Docs/CustomKernel
  
Actual results:

In file included from scripts/kconfig/lxdialog/checklist.c:24:
scripts/kconfig/lxdialog/dialog.h:32:20: error: curses.h: Arquivo ou diretório
não encontrado
In file included from scripts/kconfig/lxdialog/checklist.c:24:
scripts/kconfig/lxdialog/dialog.h:97: error: expected specifier-qualifier-list
before ‘chtype’
scripts/kconfig/lxdialog/dialog.h:187: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:193: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:195: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:196: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:197: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:198: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:200: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:31: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:59: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:95: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c: In function ‘dialog_checklist’:
scripts/kconfig/lxdialog/checklist.c:116: error: ‘WINDOW’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:116: error: (Each undeclared identifier is
reported only once
scripts/kconfig/lxdialog/checklist.c:116: error: for each function it appears in.)
scripts/kconfig/lxdialog/checklist.c:116: error: ‘dialog’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:116: error: ‘list’ undeclared (first use in
this function)
scripts/kconfig/lxdialog/checklist.c:116: warning: left-hand operand of comma
expression has no effect
scripts/kconfig/lxdialog/checklist.c:129: warning: implicit declaration of
function ‘getmaxy’
scripts/kconfig/lxdialog/checklist.c:129: error: ‘stdscr’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:130: error: ‘KEY_MAX’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:131: warning: implicit declaration of
function ‘getmaxx’
scripts/kconfig/lxdialog/checklist.c:137: error: ‘COLS’ undeclared (first use in
this function)
scripts/kconfig/lxdialog/checklist.c:138: error: ‘LINES’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:140: warning: implicit declaration of
function ‘draw_shadow’
scripts/kconfig/lxdialog/checklist.c:142: warning: implicit declaration of
function ‘newwin’
scripts/kconfig/lxdialog/checklist.c:143: warning: implicit declaration of
function ‘keypad’
scripts/kconfig/lxdialog/checklist.c:143: error: ‘TRUE’ undeclared (first use in
this function)
scripts/kconfig/lxdialog/checklist.c:145: warning: implicit declaration of
function ‘draw_box’
scripts/kconfig/lxdialog/checklist.c:146: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:146: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:147: warning: implicit declaration of
function ‘wattrset’
scripts/kconfig/lxdialog/checklist.c:147: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:148: warning: implicit declaration of
function ‘mvwaddch’
scripts/kconfig/lxdialog/checklist.c:150: warning: implicit declaration of
function ‘waddch’
scripts/kconfig/lxdialog/checklist.c:151: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:154: warning: implicit declaration of
function ‘print_title’
scripts/kconfig/lxdialog/checklist.c:156: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:157: warning: implicit declaration of
function ‘print_autowrap’
scripts/kconfig/lxdialog/checklist.c:164: warning: implicit declaration of
function ‘subwin’
scripts/kconfig/lxdialog/checklist.c:171: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:171: error: ‘struct dialog_color’ has no
member named ‘atr’
scripts/kconfig/lxdialog/checklist.c:189: warning: implicit declaration of
function ‘print_item’
scripts/kconfig/lxdialog/checklist.c:192: warning: implicit declaration of
function ‘print_arrows’
scripts/kconfig/lxdialog/checklist.c:195: warning: implicit declaration of
function ‘print_buttons’
scripts/kconfig/lxdialog/checklist.c:197: warning: implicit declaration of
function ‘wnoutrefresh’
scripts/kconfig/lxdialog/checklist.c:199: warning: implicit declaration of
function ‘doupdate’
scripts/kconfig/lxdialog/checklist.c:202: warning: implicit declaration of
function ‘wgetch’
scripts/kconfig/lxdialog/checklist.c:210: error: ‘KEY_UP’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:210: error: ‘KEY_DOWN’ undeclared (first
use in this function)
scripts/kconfig/lxdialog/checklist.c:220: error: ‘FALSE’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:221: warning: implicit declaration of
function ‘scrollok’
scripts/kconfig/lxdialog/checklist.c:222: warning: implicit declaration of
function ‘wscrl’
scripts/kconfig/lxdialog/checklist.c:232: warning: implicit declaration of
function ‘wrefresh’
scripts/kconfig/lxdialog/checklist.c:293: warning: implicit declaration of
function ‘delwin’
scripts/kconfig/lxdialog/checklist.c:297: error: ‘KEY_LEFT’ undeclared (first
use in this function)
scripts/kconfig/lxdialog/checklist.c:298: error: ‘KEY_RIGHT’ undeclared (first
use in this function)
scripts/kconfig/lxdialog/checklist.c:310: warning: implicit declaration of
function ‘on_key_esc’
scripts/kconfig/lxdialog/checklist.c:312: error: ‘KEY_RESIZE’ undeclared (first
use in this function)
make[1]: ** [scripts/kconfig/lxdialog/checklist.o] Erro 1
make: ** [menuconfig] Erro 2

Expected results:
Show the 'menuconfig' curses interface

Additional info:
Missing BuildRequires: ncurses-devel in kernel spec file.
Patch attached.
Comment 1 jasonn 2007-06-17 09:49:27 EDT
Created attachment 157222 [details]
Patch for spec file
Comment 2 Ignacio Vazquez-Abrams 2007-06-17 10:06:39 EDT
ncurses-devel is not needed to rebuild the SRPM. File a bug against the
documentation instead.
Comment 3 Chuck Ebbert 2007-06-18 21:26:28 EDT

*** This bug has been marked as a duplicate of 240878 ***
Comment 4 Christian Tosta 2007-06-19 16:55:10 EDT
I discord. I don't need ncurses-devel to build the SRPM, but it is needed for
build the kernel RPMS. Perhaps the bug title can be changed to: "missing
dependency to rebuild kernel from src.rpm".

Note You need to log in before you can comment on or make changes to this bug.