Bug 244579 - kdebase: cannot overwrite/delete marked text in input field of wordpress composer
Summary: kdebase: cannot overwrite/delete marked text in input field of wordpress comp...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-17 16:41 UTC by Roland Wolters
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 17:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch provided upstream (6.45 KB, patch)
2007-06-17 16:41 UTC, Roland Wolters
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 141457 None None None Never

Description Roland Wolters 2007-06-17 16:41:05 UTC
Description of problem:
When I enter the blog article composer of my blog on wordpress.com I am faced 
with an input field (I use the normal one, not the WYSIWIG). I can enter text 
as usual. The problem is now if I mark text (with mouse or the Shift key) and 
then hit "delete" or or "backspace" or "enter" another char-key , the text is 
not removed (and maybe replaced). 
Instead the text stays there and the cursor jumps to the beginning of the 
marked position. If I pressed another char-key to replace the marked text, the 
new char is in front of the marked text (where the cursor jumped).

Version-Release number of selected component (if applicable):
3.5.6

How reproducible:
Every time.

Additional info:
A patch is available upstream, just see the bug report or check this e-mail:
http://lists.kde.org/?l=kfm-devel&m=118141580921767&w=2

Comment 1 Roland Wolters 2007-06-17 16:41:05 UTC
Created attachment 157227 [details]
Patch provided upstream

Comment 2 Roland Wolters 2007-08-30 00:04:57 UTC
KDE 3.5.7 is out for quite some time now, the patch wasn't included 
unfortunately (I think it was too late already), any chance to see it in 
Fedora's KDE anytime soon?

Comment 3 Roland Wolters 2007-11-02 17:20:39 UTC
Fixed in Fedora 8 with KDE 3.5.8 - after 5 month, although a patch was 
provided with the initial entry.


Note You need to log in before you can comment on or make changes to this bug.