Bug 244585 - Device automonting in KDE fails with "Not in active session"
Device automonting in KDE fails with "Not in active session"
Status: CLOSED DUPLICATE of bug 244065
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 14:24 EDT by redhat-bugs2eran
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 10:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat-bugs2eran 2007-06-17 14:24:14 EDT
Automounting of USB devices and CD-ROM in KDE fails, with this Konqueror error:
  "Permission Denied: Not in active session"

It used to work perfectly with FC6, but is broken since I've upgraded to F7.

Running Fedora 7 + updates, and specifically: ConsoleKit-0.2.1-2.fc7
kdebase-3.5.6-12.fc7

SELinux is disabled. Logging in and out, restarting the ConsoleKit service, and
rebooting don't fix this.

Mounting directly via /usr/bin/mount works fine.

The above 100% reproducible on my machine. I don't have a fresh F7 install at hand.

In one case, I used the "Start New Session" option in KDE to open a 2nd parallel
session, and then then mounting worked from the *2nd* session. However, I'm now
unable to reproduce this effect.

$ ck-list-sessions
Session4:
        uid = '501'
        realname = 'Foo Bar'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2007-06-17T15:56:29Z'

and XDG_SESSION_COOKIE is set to a 61-char string.
Comment 1 David Zeuthen 2007-06-18 12:40:40 EDT
Does it work with gnome-mount, e.g. 'gnome-mount -d /dev/sda1' from a non-root
terminal? Thanks.
Comment 2 redhat-bugs2eran 2007-06-18 22:46:33 EDT
Yes, gnome-mount works fine from a shell within the same session. Interesting.
BTW, I'm using kdm.
Comment 3 David Zeuthen 2007-06-19 10:09:05 EDT

*** This bug has been marked as a duplicate of 244065 ***

Note You need to log in before you can comment on or make changes to this bug.