Bug 244586 - Liferea crashes repeatingly on a RSS feed
Summary: Liferea crashes repeatingly on a RSS feed
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: liferea   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-17 18:37 UTC by Emmanuel Seyman
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version: 1.4.8-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 20:48:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Planet Mozilla RSS 2.0 feed as of 5 minutes ago (176.87 KB, text/xml)
2007-07-17 21:57 UTC, Emmanuel Seyman
no flags Details

Description Emmanuel Seyman 2007-06-17 18:37:07 UTC
Description of problem:
Liferea crashes when you select an item from squadtv.com's RSS feed

Version-Release number of selected component (if applicable):
1.2.15b-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Add SquadTV.com's RSS feed to liferea
2. Click on anyone of the news item that Liferea presents
3. Watch Liferea crash
  
Actual results:
Liferea crashes. When it is launced from the command line, the following error
is displayed :

(liferea:24765): Pango-WARNING **: shape engine failure, expect ugly output. the
offending font is 'DejaVu LGC Sans Not-Rotated 0'

Liferea did receive signal 11 (Erreur de segmentation).

Expected results:
Liferea should not crash

Additional info:
Looks like someone has already reported it to upstream :
http://sourceforge.net/tracker/index.php?func=detail&aid=1736302&group_id=87005&atid=581684

Comment 1 Brian Pepple 2007-07-15 02:20:03 UTC
Which plugin are you using? gtkhml2 or Firefox?  If you are using the gtkhtml2
plugin, could you try the firefox plugin and see if it crashes.

Comment 2 Emmanuel Seyman 2007-07-17 21:55:08 UTC
Okay, here's the deal.

I can reproduce this consistently on Planet Mozilla RSS 2.0 feed.
Using the gtkhtml2 plug-in, I crash with a signal 11 on the entry 
"Doug Turner: Joey and the IPhone".
Using the mozilla plug-in, liferea never crashes.


Comment 3 Emmanuel Seyman 2007-07-17 21:57:10 UTC
Created attachment 159478 [details]
Planet Mozilla RSS 2.0 feed as of 5 minutes ago

Comment 4 Brian Pepple 2007-12-01 23:18:46 UTC
Are you still experiencing this bug in the 1.4.x branch?

Comment 5 Emmanuel Seyman 2007-12-03 20:48:50 UTC
No, I can't reproduce, even with the RSS feed in the attachement.
Resolving as WORKSFORME


Note You need to log in before you can comment on or make changes to this bug.