Bug 244616 - Installing OS fails on ATI/AMD SB700 chipset with AHCI mode
Installing OS fails on ATI/AMD SB700 chipset with AHCI mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-17 23:58 EDT by Shane Huang
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.6.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 07:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Huang 2007-06-17 23:58:18 EDT
+++ This bug was initially created as a clone of Bug #244156 +++

Description of problem: cannot find hard disk device while setting the SATA 
mode to AHCI mode in system BIOS


Version-Release number of selected component (if applicable):
2.6.18

How reproducible:
always

Steps to Reproduce:
1.the onchip SATA mode to AHCI mode
2.install OS
  
Actual results:
cannot find AHCI driver

Expected results:
find the AHCI driver for hard disk

Additional info:
This patch will be included in the linux kernel from version 2.6.22

-- Additional comment from henry.su@amd.com on 2007-06-14 03:58 EST --
Created an attachment (id=156964)
patch: add the AHCI device ID


-- Additional comment from bnagendr@redhat.com on 2007-06-14 09:47 EST --
Upstream commit:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commi
t;h=2bcfdde6767f2f07891d2753c25220012fe5e6d2



-- Additional comment from bnagendr@redhat.com on 2007-06-14 09:51 EST --
Asked AMD to send a SB700 reference board for the SB700 back ports.

-- Additional comment from rdoty@redhat.com on 2007-06-14 13:44 EST --
Is this a bug or new hardware enablement?

-- Additional comment from prarit@redhat.com on 2007-06-14 13:54 EST --
(In reply to comment #5)
> Is this a bug or new hardware enablement?

Feature Request-- new hw enablement.

P.
Comment 1 Matthew Saltzman 2007-08-21 17:20:21 EDT
I have this same issue with my Thinkpad T61.  The device should be supported by
the ahci driver, but it is not found at boot.  This applies to the install
process and to booting after installation is complete.  The problem is still
present in kernel-2.6.22.1-41.fc7.

Lenovo (by Intel) / 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [SATA
controller]

Should I file a separate bug or is this OK?
Comment 2 Alan Cox 2007-08-21 17:38:23 EDT
Seperate bug please - differing hardware, and assign it to jgarzik@redhat.com
Comment 3 Christopher Brown 2007-09-17 07:08:44 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

The information contained herein indicates this is resolved from kernel 2.6.22
so I am closing. If I have erred, please accept my profuse apologies and re-open
and I will attempt to assist in its resolution.

Cheers
Chris
Comment 4 Shane Huang 2007-09-19 23:44:54 EDT
yep, you may close this bug, and I find FC8 Test 2 contains this patch.

Note You need to log in before you can comment on or make changes to this bug.