Bug 244625 - Gnome volume control applet crashes frequently
Gnome volume control applet crashes frequently
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 01:37 EDT by Rogue
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace of the crash (24.69 KB, text/plain)
2007-06-18 01:37 EDT, Rogue
no flags Details

  None (edit)
Description Rogue 2007-06-18 01:37:17 EDT
Description of problem:
Gnome volume control applet tends to keep crashing everytime I try to change my
preferences.

Version-Release number of selected component (if applicable):
2.18.0-3.fc7

How reproducible:
Everytime

Steps to Reproduce:
1. Try muting and unmuting a few of the controls. Then add a control from the
preferences screen, now change its state.
2. Now remove that control using the preferences screen.
3. Close the applet
  
Actual results:
1. Bug buddy comes up with crash details
2. This somehow messes up the gconf settings, rendering the desktop unusable the
next time it loads up
3. I need to remove the sound entry keys from ~/.gconf directory and get my
desktop back.

Expected results:
1. The applet should close without crashing
2. It should not mess up the gconf settings to the point that the desktop can
not be brought up again!

Additional info:
Since bug buddy is unable to file a bug against this component (this issue is
tracked via #244526), I had installed the devel packages and saved the stack to
a file. Attaching the file to this bug report.
Comment 1 Rogue 2007-06-18 01:37:18 EDT
Created attachment 157255 [details]
Stack trace of the crash
Comment 2 Bastien Nocera 2007-08-20 10:10:55 EDT
Could you please gather a stack trace with debuginfo packages installed? See
http://fedoraproject.org/wiki/StackTraces for details.

I have a hard time believing this could make the desktop unusable though. If
something crashes or hangs when starting the desktop, please report a new bug.
Comment 3 Rogue 2007-08-20 14:41:41 EDT
Hi Bastien,

Well,off late things seem to be stable. But trust me, once the gconf entries get
messed up, then the next time I restart the system, I can do a login, but I end
up with a background image only!!! No panel, no menus, nothing... zilch!

I am closing this bug since I am no longer able to reproduce this issue, but
since I have already downloaded the debug packages, I shall open the bug if it
happens again.

thanks,
Rogue
Comment 4 Bastien Nocera 2007-08-20 14:43:48 EDT
It's probably the old esound bug that made the panel and a number of apps hang,
if you had enabled it in the prefs. Latest esound in F7 should have the bug fix.

Note You need to log in before you can comment on or make changes to this bug.