Bug 244632 - nisdomain not set during kickstart
nisdomain not set during kickstart
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 04:25 EDT by Herbert Gasiorowski
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 04:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Herbert Gasiorowski 2007-06-18 04:25:45 EDT
Description of problem:
Using kickstart
   auth --useshadow --enablenis --nisdomain xxxxxxx
no "NISDOMAIN=xxxxxxx" is found in /etc/sysconfig/network

How reproducible:
Always


authconfig does not change the behavior.
It works fine with fedora 6 and Redhat 4.5 and 5.0
(The same fault probably has been in older Versions, as there is
a comment line
   #echo "NISDOMAIN=xxxxxxx" >> /etc/sysconfig/network
in my %post section
Comment 1 Tomas Mraz 2007-06-18 11:36:43 EDT
I suspect something overwrites the /etc/sysconfig/network as written by
authconfig. When I run authconfig standalone the command 'authconfig --useshadow
--enablenis --nisdomain xxxxxx --update' works fine.

Can you try to do that after install?
Comment 2 Herbert Gasiorowski 2007-06-19 04:24:45 EDT
Sorry - It is not a bug:

A fresh install without any changes has been ok!

It took me a while to find out:
The nis-domain is no longer set in /etc/sysconfig/network but in
/etc/yp.conf - which is overwritten by me during %post installation!


Note You need to log in before you can comment on or make changes to this bug.