Bug 244636 - fixfiles appears to hang on reboot
fixfiles appears to hang on reboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: policycoreutils (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
: 239562 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 05:28 EDT by Jose Plans
Modified: 2010-10-22 11:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0787
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:07:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixfiles-return-code.patch (328 bytes, patch)
2007-06-18 05:28 EDT, Jose Plans
no flags Details | Diff

  None (edit)
Description Jose Plans 2007-06-18 05:28:30 EDT
Description of problem: 
if /.autorelabel is created, fixfiles appears to hang after it is run. In
actuality is it waiting on some user input.

How reproducible:
always when using /.autorelabel

Steps to Reproduce:
touch /.autorelabel
reboot

Actual results:
fixfiles appears to hang

Expected results:
fixfiles exits cleanly

Additional info:
The attached patch fixes this.
Comment 1 Jose Plans 2007-06-18 05:28:32 EDT
Created attachment 157263 [details]
fixfiles-return-code.patch
Comment 5 Daniel Walsh 2007-06-22 11:55:59 EDT
*** Bug 239562 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Walsh 2007-06-22 11:57:45 EDT
Fixed in policycoreutils-1.18.1-4.13
Comment 13 errata-xmlrpc 2007-11-15 11:07:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0787.html

Note You need to log in before you can comment on or make changes to this bug.