Bug 244642 - ooo dies with hunspell
ooo dies with hunspell
Status: CLOSED DUPLICATE of bug 243811
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 06:44 EDT by Anton Guda
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 10:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2007-06-18 06:44:21 EDT
Description of problem:
ooo programs, like writer, exits without
coredump or error messsages on spellchecking.

Version-Release number of selected component (if applicable):

openoffice.org-*-2.2.1-18.1.fc8
hunspell-1.1.5.3-4

How reproducible:
always


Steps to Reproduce:
1. start oowriter
2. open document with some spell errors.
3. try to scroll/modify text
  
Actual results:
oowriter exits without error messages.

Expected results:
oowriter must be alive even spell subsystem crashes.

Additional info:
If we rename directory /usr/share/myspell,
oowriter (oo*) works, but without spellckecking.

It was similar bug #233361, but in this case
there is no error messages.
Comment 1 Caolan McNamara 2007-06-18 06:53:40 EDT
It might not really be hunspell per-se, but the fact that the redlines get drawn
triggering a drawing problem with cairo. i.e. what happens if from a terminal
you run it from a gnome-terminal after 

export SAL_IGNOREXERRORS=YES

is set ? This may be another manifestation of the cairo problem of bug 243811
Comment 2 Anton Guda 2007-06-18 10:47:34 EDT
With
SAL_IGNOREXERRORS=YES
it works fine.
Comment 3 Caolan McNamara 2007-06-18 10:54:08 EDT

*** This bug has been marked as a duplicate of 243811 ***

Note You need to log in before you can comment on or make changes to this bug.