Bug 244651 - removable media can't automount
removable media can't automount
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 07:46 EDT by Longinos Ferrando
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 12:33:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Longinos Ferrando 2007-06-18 07:46:30 EDT
Description of problem:
Fresh install of F7 , DELL Optiplex GX520. Fedora up2date until 15/06/2007 with
autofs-autofs-5.0.1-16. 
when I insert 1 dvd these are the output from lshal --monitor,/var/log/messages
and udevmonitor
[root@CI5724 ~]# lshal --monitor

Start monitoring devicelist:
-------------------------------------------------
13:24:22.409: storage_model_DVD_ROM_DDU1615 property
storage.removable.media_available = true
13:24:24.728: volume_label_Fedora_7_i386_DVD added
/var/log/messages and udevmonitor: no output...and no volume mount is done nor
dvd icon in the desktop
 If I run gnome-mount -d /dev/scd0 in console window this happend:

from lshal:
13:26:39.600: volume_label_Fedora_7_i386_DVD property volume.mount_point =
'/media/Fedora 7 i386 DVD'
13:26:39.602: volume_label_Fedora_7_i386_DVD property
volume.is_mounted_read_only = true
13:26:39.604: volume_label_Fedora_7_i386_DVD property volume.is_mounted = true

from /var/log/messages 
Jun 18 13:26:39 CI5724 hald: mounted /dev/scd0 on behalf of uid 0

from udevmonitor
UEVENT[1182165999.599431] mount    /block/sr0 (block)
UDEV  [1182165999.600308] mount    /block/sr0 (block)

and then the dvd icon is in the desktop
when the dvd is ejected:

from lshal:
13:31:42.330: volume_label_Fedora_7_i386_DVD property volume.mount_point = ''
13:31:42.332: volume_label_Fedora_7_i386_DVD property
volume.is_mounted_read_only = false
13:31:42.358: volume_label_Fedora_7_i386_DVD property volume.is_mounted = false
13:31:44.043: storage_model_DVD_ROM_DDU1615 property
storage.removable.media_available = false
13:31:44.062: volume_label_Fedora_7_i386_DVD removed

from /var/log/messages
Jun 18 13:31:42 CI5724 hald: unmounted /dev/scd0 from '/media/Fedora 7 i386 DVD'
on behalf of uid 0

from udevmonitor
UEVENT[1182166302.327556] umount   /block/sr0 (block)
UDEV  [1182166302.328814] umount   /block/sr0 (block)

If I insert 1 usb pen-drive:
from lshal:
13:34:34.101: usb_device_90c_1000_14000000000000001126 added
13:34:34.212: usb_device_90c_1000_14000000000000001126_if0 added
13:34:34.228: usb_device_90c_1000_14000000000000001126_usbraw added
13:34:39.167: usb_device_90c_1000_14000000000000001126_if0_scsi_generic added
13:34:39.266: usb_device_90c_1000_14000000000000001126_if0_scsi_host added
13:34:39.268:
usb_device_90c_1000_14000000000000001126_if0_scsi_host_scsi_device_lun0 added
13:34:39.399: storage_serial_USB_FLASHDISK_14000000000000001126 added
13:34:39.675: volume_uuid_9CCD_1053 added

From /var/log/messages
Jun 18 13:34:33 CI5724 kernel: usb 5-7: new high speed USB device using ehci_hcd
and address 8
Jun 18 13:34:34 CI5724 kernel: usb 5-7: configuration #1 chosen from 1 choice
Jun 18 13:34:34 CI5724 kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Jun 18 13:34:39 CI5724 kernel: scsi 7:0:0:0: Direct-Access     USB     
FLASHDISK        2010 PQ: 0 ANSI: 0 CCS
Jun 18 13:34:39 CI5724 kernel: SCSI device sdb: 1014784 512-byte hdwr sectors
(520 MB)
Jun 18 13:34:39 CI5724 kernel: sdb: Write Protect is off
Jun 18 13:34:39 CI5724 kernel: sdb: assuming drive cache: write through
Jun 18 13:34:39 CI5724 kernel: SCSI device sdb: 1014784 512-byte hdwr sectors
(520 MB)
Jun 18 13:34:39 CI5724 kernel: sdb: Write Protect is off
Jun 18 13:34:39 CI5724 kernel: sdb: assuming drive cache: write through
Jun 18 13:34:39 CI5724 kernel:  sdb: sdb1
Jun 18 13:34:39 CI5724 kernel: sd 7:0:0:0: Attached scsi removable disk sdb
Jun 18 13:34:39 CI5724 kernel: sd 7:0:0:0: Attached scsi generic sg2 type 0

From udevmonitor
UDEV  [1182166474.097110] add      /devices/pci0000:00/0000:00:1d.7/usb5/5-7 (usb)
UEVENT[1182166474.097235] add      /class/usb_endpoint/usbdev5.8_ep00 (usb_endpoint)
UEVENT[1182166474.097306] add     
/devices/pci0000:00/0000:00:1d.7/usb5/5-7/5-7:1.0 (usb)
UEVENT[1182166474.097378] add      /class/scsi_host/host7 (scsi_host)
UEVENT[1182166474.097452] add      /class/usb_endpoint/usbdev5.8_ep81 (usb_endpoint)
UEVENT[1182166474.097531] add      /class/usb_endpoint/usbdev5.8_ep02 (usb_endpoint)
UEVENT[1182166474.097606] add      /class/usb_device/usbdev5.8 (usb_device)
UDEV  [1182166474.102225] add      /class/usb_endpoint/usbdev5.8_ep00 (usb_endpoint)
UDEV  [1182166474.102312] add      /class/scsi_host/host7 (scsi_host)
UDEV  [1182166474.202288] add     
/devices/pci0000:00/0000:00:1d.7/usb5/5-7/5-7:1.0 (usb)
UDEV  [1182166474.215050] add      /class/usb_endpoint/usbdev5.8_ep81 (usb_endpoint)
UDEV  [1182166474.216692] add      /class/usb_endpoint/usbdev5.8_ep02 (usb_endpoint)
UDEV  [1182166474.225223] add      /class/usb_device/usbdev5.8 (usb_device)
UEVENT[1182166479.096350] add     
/devices/pci0000:00/0000:00:1d.7/usb5/5-7/5-7:1.0/host7/target7:0:0/7:0:0:0 (scsi)
UEVENT[1182166479.096397] add      /class/scsi_disk/7:0:0:0 (scsi_disk)
UDEV  [1182166479.099366] add      /class/scsi_disk/7:0:0:0 (scsi_disk)
UEVENT[1182166479.149387] add      /block/sdb (block)
UEVENT[1182166479.149419] add      /block/sdb/sdb1 (block)
UEVENT[1182166479.149435] add      /class/scsi_device/7:0:0:0 (scsi_device)
UEVENT[1182166479.150116] add      /class/scsi_generic/sg2 (scsi_generic)
UDEV  [1182166479.153288] add      /class/scsi_generic/sg2 (scsi_generic)
UDEV  [1182166479.260755] add     
/devices/pci0000:00/0000:00:1d.7/usb5/5-7/5-7:1.0/host7/target7:0:0/7:0:0:0 (scsi)
UDEV  [1182166479.355193] add      /class/scsi_device/7:0:0:0 (scsi_device)
UDEV  [1182166479.385382] add      /block/sdb (block)
UDEV  [1182166479.646224] add      /block/sdb/sdb1 (block)


No mount and no device icon on the desktop
I I run gnome-mount -d /dev/sdb1
From lshal:
13:36:48.339: volume_uuid_9CCD_1053 property volume.mount_point = '/media/FLASHDISK'
13:36:48.341: volume_uuid_9CCD_1053 property volume.is_mounted = true

From /var/log/messages
Jun 18 13:36:48 CI5724 hald: mounted /dev/sdb1 on behalf of uid 0

from udevmonitor
UEVENT[1182166608.337577] mount    /block/sdb/sdb1 (block)
UDEV  [1182166608.338282] mount    /block/sdb/sdb1 (block)
and get the mount and icon on the desktop.

The user that done all these step is root and gnome desktop.


Version-Release number of selected component (if applicable):


How reproducible:
allways

Steps to Reproduce:
1.
2.
3.
  
Actual results:
no automount removable media 

Expected results:
removable media mounted

Additional info:
Comment 1 David Zeuthen 2007-06-18 12:33:46 EDT
Looks like you're logged in as root - we (currently) refuse to automount for
root; design decision. Thanks.

Note You need to log in before you can comment on or make changes to this bug.