Bug 244670 - Network Manager disconnects after initial connection
Network Manager disconnects after initial connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 09:22 EDT by markm
Modified: 2008-10-20 10:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 10:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg | tail -40 (2.00 KB, text/plain)
2007-12-10 22:09 EST, Vang Be Pha
no flags Details

  None (edit)
Description markm 2007-06-18 09:22:48 EDT
Description of problem:

Basicaly Network Manager is not able to keep existing connection.

Version-Release number of selected component (if applicable):

NetworkManager 1:0.6.5-5.fc7@i386

How reproducible:

always

Steps to Reproduce:
1. Computer starts
2. Login to the user account
3. Network Manager asks about keyring password
4. Network Manager connects to the prefered network
5. Network Manager disconnects
6. need to select my prefered network manually
7. Network Manager connects
  
Actual results:

have to manualy choose a network

Expected results:

Network Manager doesn't disconnect from the network on initial connection

Additional info:

I use ipw3945 driver from freshrpms.net repository - I use this driver, because
iwl3945 shipped with Fedora7 doesn't work at all (why you have decided to ship
driver which doesn't work?)

on daily basis I use WPA network at work and WPA2 at home - so I assume it is
not network related issue.
Comment 1 markm 2007-11-29 10:19:57 EST
as normal, network manager related issues are being ignored, but I can confirm,
that this issue hasn't been solved in Fedore 8 either. 
Comment 2 markm 2007-11-29 10:21:47 EST
although, iwl3945 works much better than on fedora 7, this issue is valid for
both iwl & ipw drivers. after initial connection it gets disconnected, then I
need to select a network manually or wait a while.
Comment 3 Vang Be Pha 2007-12-10 22:09:14 EST
Created attachment 283541 [details]
dmesg | tail -40
Comment 4 Vang Be Pha 2007-12-10 22:12:42 EST
Comment on attachment 283541 [details]
dmesg | tail -40

I posted this on fedoraforum.org and I was given the following code to
execute... I'm running a Gateway MX8738 laptop and I'm not sure if it's a
hardware problem or a software problem...  but this is what happens...

1) Keyring is asked after login
2) NM logs into preferred AP
3) NM disconnects from AP after a while
4) NM tries to connect to the AP and cycles until it times out and there is no
connection ever made...
Comment 5 Vang Be Pha 2007-12-10 22:18:27 EST
I forgot to add that when I reboot my computer it goes to 

Unloading iptables

and hangs there until I do a hard shutdown... 
Comment 6 Dan Williams 2008-10-20 10:53:16 EDT
WPA-PSK/WPA2-PSK tested working with 2.6.26.5-28.fc8, NM svn4022.4.fc8, supplicant 0.5.10-6.fc8 with ipw2200 against a Linksys WRT54GC.

Note You need to log in before you can comment on or make changes to this bug.