Bug 244676 - Duplicate export entries after editing "Hosts" field.
Duplicate export entries after editing "Hosts" field.
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-nfs (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On: 455446
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 10:01 EDT by cvcrckt
Modified: 2008-12-18 11:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 11:10:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cvcrckt 2007-06-18 10:01:26 EDT
Description of problem:

Changing the "Hosts" field of an NFS export via the "Properties" dialog results
in an extra export: after the operation an export exists for both the new and
old hosts.  The user does not see both exports until she closes and re-opens
system-config-nfs.

Version-Release number of selected component (if applicable):

1.3.23-1

How reproducible:


Steps to Reproduce:
1. Make a new export
2. Change the Hosts field
3. Close and re-open system-config-nfs
  
Actual results:

An export still exists for the original host.  Another export exists for the new
host.

Expected results:

The user edited the properties of an export.  After the operation there should
be a single entry which reflects her changes.

Additional info:
Comment 3 Phil Knirsch 2008-12-18 11:10:06 EST
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

We are currently investigating a solution and will implement a possible fix in Fedora. In case this turns out to be a viable and not too intrusive change we will reconsider to fix this in a future Red Hat Enterprise Linux update release.

Note You need to log in before you can comment on or make changes to this bug.