Bug 244683 - forcedeth-driven network card totally and irremediably out to lunch
Summary: forcedeth-driven network card totally and irremediably out to lunch
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.5
Hardware: All Linux
low
high
Target Milestone: ---
: ---
Assignee: Andy Gospodarek
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-18 14:59 UTC by Sylvain
Modified: 2014-06-29 22:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 22:16:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
details - uname / logs / dmesg / lspci (101.82 KB, text/plain)
2007-06-18 14:59 UTC, Sylvain
no flags Details

Description Sylvain 2007-06-18 14:59:49 UTC
Description of problem:
Integrated network card hangs unexpectedly and repeatedly. The card dumps its
registers in var log messages.Cold reboot (unplugging etc) seems mandatory for
the network to come back.
Did unfall straight away after install on a station, and apparently at random on
another.

Version-Release number of selected component (if applicable):

redhat kernel 2.6.9-55 ; forcedeth 0.42-rh

How reproducible:

Install and wait (heavy activity not required).

Additional info:

Attached are the snippets of /var/log/message whinings, along with uname -a,
lspci -vvv, dmesg.
The same setup has been successfully and extensively used with a stock U4 install.

Comment 1 Sylvain 2007-06-18 14:59:49 UTC
Created attachment 157286 [details]
details - uname / logs / dmesg / lspci

Comment 2 Sylvain 2007-09-17 19:04:36 UTC
I'll profite that i see the case moved forward to 'assigned' to add my latest
observations :)

 * The bug can be reproduced at greatest speed if alot of activity (seems pretty
random though)

and more proeminently:
 * The bug tends to be very present in the case of half-duplex communication (hubs)
 * The bug seems non-existent using a switch (we worked the problem around with
that since the report)
Cheers!

Comment 3 Andy Gospodarek 2007-09-17 19:38:41 UTC
A major update to forcedeth is planned for the next update.

You can always try my latest test kernels (they generally contain experimental
net-driver fixes and are regularly updated):

http://people.redhat.com/agospoda/#rhel4

For this case, you can also check the kernels available here:

http://people.redhat.com/jbaron/rhel4/

Since they contain kernels that are close to the ones that will be released with
the next RHEL4 update.


Comment 4 Andy Gospodarek 2008-04-07 22:16:44 UTC
This bug has seen no activity in quite a while, so I can only presume it is no
longer a problem.  If there is still an issue with the latest kernel that needs
to be resolved, please re-open this bug and I will be happy to help resolve it.
 Thank you.



Note You need to log in before you can comment on or make changes to this bug.