Bug 244684 - zsh dosnt source /etc/profile.d
Summary: zsh dosnt source /etc/profile.d
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-18 15:02 UTC by Carlos Ferrabone
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 18:16:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Ferrabone 2007-06-18 15:02:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070223 Firefox/2.0.0.2

Description of problem:
In a graphical session, when i start a terminal (xterm, kconsole, urxvt) the zsh runing inside (non-login interactive) dosnt have the aliases declared in /etc/profile.d
this is because in /etc/zshrc, to prevent these scripts to be sourced two times (/etc/zprofile is readed before if its a login shell), the source command is inside an IF, that checks x$SHLVL != x1 . 
the correct way to check if its not a login shell is using  [[ ! -o login ]] (as stated in the zsh users guide)

Version-Release number of selected component (if applicable):
zsh-4.2.6-1

How reproducible:
Always


Steps to Reproduce:
1. run a terminal
2. execute the command alias "ll"


Actual Results:
zsh: command not found: ll


Expected Results:
ls -l (as defined in an alias in /etc/profile.d/colorls.sh)

Additional info:

Comment 1 Felipe Contreras 2007-07-16 20:16:09 UTC
I confirm the bug, and the solution. On Fedora 7.

I'm increasing the severity because actually it's very annoying.

Comment 2 James Antill 2007-10-11 18:16:45 UTC
 Should be fixed in just built zsh-4.3.4-4.fc8


Note You need to log in before you can comment on or make changes to this bug.