Bug 244687 - slapd does not create .pid file
slapd does not create .pid file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 11:17 EDT by Jan Safranek
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0739
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:04:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2007-06-18 11:17:42 EDT
Description of problem:

running 'service ldap start' will not create /var/run/slapd.pid. The reason is
the slapd resigns root priviledges too early and 'ldap' uses does not have right
to create the .pid file.

Version-Release number of selected component (if applicable):

net-snmp-libs-5.1.2-11.EL4.10

How reproducible:
always

Steps to Reproduce:
1. service slapd start
  
Actual results:
no slapd.pid in /var/run/

Expected results:
slapd.pid exists in /var/run/

Additional info:
Fixed in RHEL 5: new directory /var/run/openldap is created with enough
priviledges to create the pid file by slapd.
Comment 1 RHEL Product and Program Management 2007-06-18 11:44:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Jan Safranek 2007-06-19 04:35:23 EDT
Just a correction of the bug report:

Version-Release number of selected component (if applicable):
openldap-servers-2.2.13-6
Comment 7 errata-xmlrpc 2007-11-15 11:04:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0739.html

Note You need to log in before you can comment on or make changes to this bug.