Bug 244760 - ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-18 20:53 EDT by srinivas varadaraj
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-29 19:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description srinivas varadaraj 2007-06-18 20:53:56 EDT
Description of problem:
ATA driver ( pata_via 0000:00:0f.0: version 0.2.1 ).

Version-Release number of selected component (if applicable):
version 0.2.1

lspci -v output

00:0f.0 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) (prog-if 8a
[Master SecP PriP])
        Subsystem: VIA Technologies, Inc.
VT82C586/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE
        Flags: bus master, medium devsel, latency 32, IRQ 17
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
        I/O ports at e100 [size=16]
        Capabilities: [c0] Power Management version 2

The primary controller is disabled on startup and the drives are not recognized.
Write protecting the kernel read-only data: 800k
libata version 2.20 loaded.
pata_via 0000:00:0f.0: version 0.2.1
ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001e100 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001e108 irq 15
scsi0 : pata_via
ata1.00: qc timeout (cmd 0xa1)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1: failed to recover some devices, retrying in 5 secs
ata1: port is slow to respond, please be patient (Status 0x80)
ata1: port failed to respond (30 secs, Status 0x80)
ata1.01: n_sectors mismatch 0 != 488397168
ata1.01: revalidation failed (errno=-19)
ata1.01: limiting speed to UDMA7:PIO5
ata1: failed to recover some devices, retrying in 5 secs
ata1.01: n_sectors mismatch 0 != 488397168
ata1.01: revalidation failed (errno=-19)
ata1.01: disabled
scsi1 : pata_via
ata2.00: ATA-4: ST310210A, 3.21, max UDMA/66
ata2.00: 19925880 sectors, multi 16: LBA 
ata2.01: ata_hpa_resize 1: sectors = 312581808, hpa_sectors = 312581808
ata2.01: ATA-6: WDC WD1600JB-22GVA0, 08.02D08, max UDMA/100
ata2.01: 312581808 sectors, multi 16: LBA48 
ata2.00: configured for UDMA/66
ata2.01: ata_hpa_resize 1: sectors = 312581808, hpa_sectors = 312581808
ata2.01: configured for UDMA/100

However secondary controller operates correctly, as visible  in the log.
Also, this problem didn't exist in FC6 ( prob because of different driver ).
Here is the kernel version number
Linux pdc 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:39:26 EDT 2007 i686 i686 i386
GNU/Linux
Comment 1 srinivas varadaraj 2007-06-18 22:37:11 EDT
An update on the problem, I had a DVDRW drive ( Liteon SOWO 1693) as primary
master. I disconnected this and the HDD ( primary slave ) was detected. Seems
like the driver timedout and shutoff the adapter on encountering a bad drive. I
haven't tried the firmware update issued by Liteon yet. Will post when I have an
update.
Comment 2 Christopher Brown 2007-09-17 07:18:38 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 3 srinivas varadaraj 2007-09-17 09:26:41 EDT
I still have the drive disconnected, I will reconnect and post an update tonight.
Thanks 
-sri
Comment 4 srinivas varadaraj 2007-09-29 15:43:16 EDT
An update, I have connected the drive back and the kernel I am running is
Linux pdc 2.6.22.5-76.fc7 #1 SMP Thu Aug 30 12:56:15 EDT 2007 i686 i686 i386
GNU/Linux
It seems to to correctly bypass the bad drive during startup , however it still
leaves the ATA controller on. I believe this issue can be closed.

ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001e200 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001e208 irq 15
usb 5-2: new high speed USB device using ehci_hcd and address 2
usb 5-2: configuration #1 chosen from 1 choice
usb 1-2: USB disconnect, address 2
usb 2-1: new full speed USB device using uhci_hcd and address 2
usb 2-1: configuration #1 chosen from 1 choice
usb 2-2: new low speed USB device using uhci_hcd and address 3
usb 2-2: configuration #1 chosen from 1 choice
hiddev96: USB HID v1.10 Device [CPS UPS AE550] on usb-0000:00:10.1-2
ata1.00: qc timeout (cmd 0xa1)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1: failed to recover some devices, retrying in 5 secs
ata1.01: n_sectors mismatch 0 != 488397168
ata1.01: revalidation failed (errno=-19)
ata1.01: limiting speed to UDMA7:PIO5
ata1: failed to recover some devices, retrying in 5 secs
ata1.00: ATAPI: LITE-ON DVDRW SOHW-1693S, KS04, max UDMA/66
ata1.00: configured for UDMA/66
ata1.01: configured for UDMA/100
ata2.00: ATA-4: ST310210A, 3.21, max UDMA/66
ata2.00: 19925880 sectors, multi 16: LBA 
ata2.01: ATA-6: WDC WD1600JB-22GVA0, 08.02D08, max UDMA/100

Comment 5 Christopher Brown 2007-09-29 19:31:09 EDT
Okay, thanks for your comments srinivas. Closing as requested...

Note You need to log in before you can comment on or make changes to this bug.