Bug 244761 - [RHEL5] null hotkey system config overridden by hardcoded defaults
Summary: [RHEL5] null hotkey system config overridden by hardcoded defaults
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scim
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Peng Huang
QA Contact:
URL:
Whiteboard:
Depends On: 219247
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-19 01:07 UTC by Jens Petersen
Modified: 2013-04-12 19:11 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0490
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-04 07:55:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0490 normal SHIPPED_LIVE scim bug fix update 2008-06-04 07:55:30 UTC

Description Jens Petersen 2007-06-19 01:07:15 UTC
Description of problem:
Next/previous factory hotkeys are only supposed to be defined for Chinese
locale by default, but actually get set for all locale.  This appear to
be a bug of initial-locale-hotkey-186861.patch.

Steps to Reproduce:
1. login as new user and start gedit
2. Try Ctrl+Shift+Release or Shift+Control+Release
  
Actual results:
IME (factory) changes no matter the locale.

Expected results:
Should only change for users starting in Chinese locale.

-- Additional comment from petersen@redhat.com on 2006-12-12 18:14 EST --
Fixing in next scim build.

-- Additional comment from petersen@redhat.com on 2006-12-15 03:38 EST --
This should be fixed in 1.4.5-7.fc7.

Comment 1 Jens Petersen 2007-09-07 05:33:12 UTC
Setting dev_ack since fix exists in fedora already.

Comment 2 RHEL Product and Program Management 2007-12-03 20:43:29 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.

Comment 5 Jens Petersen 2008-02-15 04:50:32 UTC
Fix is in updated "initial-locale-hotkey-186861.patch" in Fedora.

Comment 6 RHEL Product and Program Management 2008-02-15 04:59:13 UTC
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.

Comment 8 Peng Huang 2008-05-20 08:25:24 UTC
Fixed in scim-1.4.4-41.el5

Comment 12 errata-xmlrpc 2008-06-04 07:55:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0490.html


Note You need to log in before you can comment on or make changes to this bug.