Bug 244770 - add scim meta packages to handle language support groups better
add scim meta packages to handle language support groups better
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 229742
  Show dependency treegraph
 
Reported: 2007-06-18 23:51 EDT by Jens Petersen
Modified: 2013-01-09 20:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 21:45:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
comps.xml-f8.xml.in-scim-meta.patch (10.75 KB, patch)
2007-06-18 23:51 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Jens Petersen 2007-06-18 23:51:02 EDT
Description of problem:
For F8 I am planning to add meta packages to scim to handle the scim
core package requirements for language support better.  With this change
scim no longer needs to be installed by default for all users.

Steps to Reproduce:
1. install Fedora as desktop
  
Actual results:
scim, scim-m17n and scim-bridge are installed by default.

Expected results:
scim, scim-m17n and scim-bridge not to be installed as they are
not useful without IM Engines or m17n-db input maps.
Comment 1 Jens Petersen 2007-06-18 23:51:03 EDT
Created attachment 157344 [details]
comps.xml-f8.xml.in-scim-meta.patch
Comment 2 Jesse Keating 2007-06-19 07:38:23 EDT
This seems mostly OK, however I'm curious about conditionalizing on
xorg-x11-server-Xorg.  Does scim not work via ssh x11 forwarding, or is it
directly tied to the X server handling the windows?

Either way, comps is open to all for writing, you can apply the patch at any
time you see fit.
Comment 3 Jens Petersen 2007-06-19 21:44:05 EDT
(In reply to comment #2)
> I'm curious about conditionalizing on xorg-x11-server-Xorg.
> Does scim not work via ssh x11 forwarding, or is it
> directly tied to the X server handling the windows?

No it works over ssh too. The condition on xorg-x11-server-Xorg is "historical"
I think, copied from other comps entries when it was added.

What would be a better "dependency" so that it would not be installed
by default on a server or minimal install?  Maybe gtk2?

(Otherwise if it is superfluous we could also drop those conditions I suppose.)
Comment 4 Jesse Keating 2007-06-25 11:21:40 EDT
I just saw a bunch of scim comps checkins, does that resolve this bug?
Comment 5 Jens Petersen 2007-06-25 21:45:53 EDT
Yes, that's right.

I left the conditionals at xorg-x11-server-Xorg for now since that
is what we have been using for now.  Perhaps we can improve that later.

Note You need to log in before you can comment on or make changes to this bug.