Bug 244787 - incorrect default keymaps
incorrect default keymaps
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2007-06-19 03:44 EDT by Per Steinar Iversen
Modified: 2009-09-15 03:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.400.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-15 03:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
virtual machine file (919 bytes, text/xml)
2008-07-01 17:01 EDT, Christoph Höger
no flags Details

  None (edit)
Description Per Steinar Iversen 2007-06-19 03:44:01 EDT
Description of problem:

I run F7 with a Norwegian keyboard. When installing windows xp as a client
under virt-manager I also use the Norwegian layout. But windows is the not
able to see or correctly use all national characters on the keyboard.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install windows xp under virt-manager.
2. Set keyboard to Norwegian.
3. Some characters then does not work correctly.
Actual results:

Problems actually using windows.

Expected results:

All the keys should work.

Additional info:

English Windows XP with Norwegian keyboard.
Comment 1 Thomas Antony 2007-06-21 12:11:13 EDT
I do have the same problem.
I'm running F7 with a german keyboard layout and installed a german Windows
Server 2003 and a german Windows XP. Both have set the german keyboard layout,
but it is a little bit english and a little bit from a other layout.
Comment 2 Red Hat Bugzilla 2007-07-24 22:14:32 EDT
change QA contact
Comment 3 Nikos Charonitakis 2008-03-23 17:29:12 EDT
i have also problem with (Greek)keyboard. I installed f9 alpha under
virt-manager and i cant type numbers (number keys show only upper symbols) also
i cant type dot (shows >) and cap locks have exactly thew opposite behaviour
Comment 4 Cole Robinson 2008-05-08 11:16:22 EDT
To all commenters: what is your KEYTABLE entry in /etc/sysconfig/keyboard?
virt-manager reads this and attempts to do the right thing when setting up a vnc
console. Also, try 'virsh dumpxml <guestname>', and see if the <graphics> tag
has a keymap= setting. If so, paste that as well.

Basically, your host machine keymap must match your vnc keymap, which must match
the keymap in the guest for this to all work. The problems you are seeing is
most likely a result of an improperly set up vnc keymap.

Comment 5 Bug Zapper 2008-05-13 22:59:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 6 Brennan Ashton 2008-06-07 23:32:47 EDT
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 7 Christoph Höger 2008-07-01 16:58:42 EDT

I am having the same issues with a german layout.

[root@choeger6 ~]# cat /etc/sysconfig/keyboard 

I will also attach my virtual machine configuration.

Comment 8 Christoph Höger 2008-07-01 17:01:44 EDT
Created attachment 310724 [details]
virtual machine file
Comment 9 Christoph Höger 2008-07-03 10:23:22 EDT
You can easily work around that by setting the qemu -k option (see man page for

This worked for me:

[root@choeger6 ~]# cat /usr/bin/qemu-kvm
/usr/bin/qemu-kvm.bin -k de $@

(except that ALT-GR did not work, but I consider this a vnc problem)

Comment 10 Nikos Charonitakis 2008-12-19 20:07:07 EST
<graphics type='vnc' port='-1' autoport='yes' keymap='en-us'/>


this is from F10. Problem remains
Comment 11 Cole Robinson 2009-02-15 23:05:40 EST
Comment #10 (Nikos), which of these keymaps sounds like the best fit?

ar  de-ch  es  fo     fr-ca  hu  ja  mk     no  pt-br  sv
da  en-gb  et  fr     fr-ch  is  lt  nl     pl  ru     th
de  en-us  fi  fr-be  hr     it  lv  nl-be  pt  sl     tr
Comment 12 Cole Robinson 2009-02-16 09:54:44 EST
Okay, I've committed a fix upstream that will make a lot of these issues go away in the future (and make my life easier):


This fixes the mapping for Comment #9 (Christoph Höger), but I still need info from Comment #10 (Nikos) to determine the ideal mapping (please see Comment #11)

Moving to POST in the interim.
Comment 13 Nikos Charonitakis 2009-02-16 18:41:22 EST
(In reply to comment #11)
> Comment #10 (Nikos), which of these keymaps sounds like the best fit?
> ar  de-ch  es  fo     fr-ca  hu  ja  mk     no  pt-br  sv
> da  en-gb  et  fr     fr-ch  is  lt  nl     pl  ru     th
> de  en-us  fi  fr-be  hr     it  lv  nl-be  pt  sl     tr

I cant see any Greek keymap in the above options.
Anyway this is a console only thing so i suppose en-us will be the most appropriate solution.
Comment 14 Daniel Berrange 2009-02-17 04:42:48 EST
Ideally we should now stop ever setting a keymap flag for new KVM/Xen. The latest QEMU VNC code has a special VNC extension which lets us pass raw scancodes to the guest.  By removing the keymap, we thus let the guest OS have total control over the scancode -> keycode -> keysym translation, and avoid needing to create every single keyboard map in QEMU
Comment 15 Cole Robinson 2009-02-18 10:48:36 EST
What packages and versions are at play here? KVM, gtk-vnc, qemu? Should we only drop this for rawhide/f11 or f9/f10? Maybe libvirt should just skip setting the keymap (even if one is passed) for sufficiently new versions of qemu or kvm, since it's already grabbing that version information.
Comment 16 Fedora Update System 2009-03-04 11:51:42 EST
python-virtinst-0.400.2-1.fc10 has been submitted as an update for Fedora 10.
Comment 17 Fedora Update System 2009-03-05 11:33:11 EST
python-virtinst-0.400.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2403
Comment 18 Fedora Update System 2009-03-10 01:25:06 EDT
python-virtinst-0.400.3-1.fc10 has been submitted as an update for Fedora 10.
Comment 19 Fedora Update System 2009-03-11 14:01:44 EDT
python-virtinst-0.400.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2612
Comment 20 Magnus Glantz 2009-05-07 17:18:41 EDT
Correct keyboard maps for Fedora Core 10 (generated by system-config-keyboard):

ar-azerty, ar-azerty-digits, ar-digits, ar-qwerty, ar-qwerty-digits, be-latin1, ben, ben-probhat, bg_bds-utf8, bg_pho-utf8, br-abnt2, cf, croat, cz-lat2, cz-us-qwertz, de, de-latin1, de-latin1-nodeadkeys, dev, dk, dk-latin1, dvorak, es, et, fi, fi-latin1, fr, fr-latin1, fr-latin9, fr-pc, fr_CH, fr_CH-latin1, gr, guj, gur, hu, hu101, ie, is-latin1, it, it-ibm, it2, jp106, ko, la-latin1, mk-utf, nl, no, pl2, pt-latin1, ro, ro-cedilla, ro-std, ro-std-cedilla, ru, sg, sg-latin1, sk-qwerty, slovene, sr-cy, sr-latin, sv-latin1, tml-inscript, tml-uni, trq, ua-utf, uk, us, us-acentos

I'm running a Swedish (sv-latin1) keyboard map and are experiencing the same issues.

Perhaps a stupid questions, but, should the python-virtinst-fix apply for already installed virtual machines? (I'm thinking not, reading the name of the package..)

This problem is persistent in:

I'm trying out python-virtinst.noarch 0:0.400.3-1.fc10 but haven't had time to do an install yet. For already installed machines, it's the same problem. I'll get back with info as soon as I've done an install.
Comment 21 Cole Robinson 2009-05-07 17:25:03 EDT
It won't change the setup for existing machines. You can remove the vnc device via virt-manager, and re-add it with a proper keymap (you probably want 'sv' ) to try and sort it out.
Comment 22 Bug Zapper 2009-06-09 18:39:59 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 23 Bug Zapper 2009-07-15 04:22:49 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 24 Mark McLoughlin 2009-08-11 12:31:28 EDT
Does this still happen on Fedora 10. Does this update help?

Comment 25 Fedora Update System 2009-09-15 03:51:54 EDT
python-virtinst-0.400.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.