Bug 244844 - at/batch won't deliver email
Summary: at/batch won't deliver email
Status: CLOSED DUPLICATE of bug 243064
Alias: None
Product: Fedora
Classification: Fedora
Component: at   
(Show other bugs)
Version: 7
Hardware: i386 Linux
low
high
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-19 13:57 UTC by ptomblin
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 13:24:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ptomblin 2007-06-19 13:57:11 UTC
Description of problem:
When the at/batch job finishes, the attempt to deliver the email fails with the
message "Jun 19 09:24:58 allhats atd[19566]: Open of jobfile failed: Success"
and then atd dies.

Version-Release number of selected component (if applicable):
at-3.1.10-11.fc7

How reproducible:
Every time.

Steps to Reproduce:
1. Submit a batch job that produces email, like "echo 'yes'"
2. Restart service atd if it's dead

  
Actual results:
atd is dead.
The message "atd[19504]: Open of jobfile failed: Success" is in /var/log/messages
The actual output of the at job is in /var/spool/at/spool.
The batch job file is still in /var/spool/at

Expected results:
An email is sent to me.
atd continues to run.
The message and job files are cleaned up from their respective directories.

Additional info:

Comment 1 ptomblin 2007-06-21 21:03:47 UTC
Not sure if it's relevant, but this system has been progressively upgraded from
RedHat 6 or so, and had only just been upgraded from Fedora Core 5 to Fedora 7.

Comment 2 Steve Stavropoulos 2007-06-23 22:55:14 UTC
This same bug is described here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=243064 and here: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=224597


Comment 3 Marcela Mašláňová 2007-06-25 13:24:22 UTC

*** This bug has been marked as a duplicate of 243064 ***


Note You need to log in before you can comment on or make changes to this bug.