Bug 244867 - ccs_tool update fails after node fenced
ccs_tool update fails after node fenced
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
: 339471 (view as bug list)
Depends On:
Blocks: 238726
  Show dependency treegraph
 
Reported: 2007-06-19 11:41 EDT by Lon Hohberger
Modified: 2009-04-16 18:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0575
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:59:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (899 bytes, patch)
2007-06-19 11:41 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2007-06-19 11:41:36 EDT
Description of problem:

Ryan McCabe found this one; we just fixed it.  If you fence a node in a RHEL5
cluster, ccs_tool update will no longer work, and will complain with: 

Unable to open connection to maggie.lab.boston.redhat.com: Bad file descriptor

Failed to update config file.

Version-Release number of selected component (if applicable):

How reproducible: 100%

Steps to Reproduce: 
1. Form cluster
2. Uncleanly kill a node so that it is fenced
3. Update config
4. try to send new config to cluster
  
Actual results:
Fail


Expected results:
Success



Additional info:
Comment 1 Lon Hohberger 2007-06-19 11:41:36 EDT
Created attachment 157384 [details]
Fix
Comment 3 RHEL Product and Program Management 2007-06-19 11:56:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 errata-xmlrpc 2007-11-07 11:59:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0575.html
Comment 7 Ryan O'Hara 2007-12-14 11:56:22 EST
*** Bug 339471 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.