Bug 244899 - brp-java-repack-jars redefines TMPDIR while using mktemp
brp-java-repack-jars redefines TMPDIR while using mktemp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
: EasyFix
Depends On: 235614
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 14:51 EDT by Jon Masters
Modified: 2011-02-10 08:21 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0470
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Masters 2007-06-19 14:51:21 EDT
+++ This bug was initially created as a clone of Bug #235614 +++

Description of problem:

mktemp uses the TMPDIR environment variable. The brp-java-repack-jars script
resets TMPDIR to arbitrary values that don't necessarily exist, and then tries
to use mktemp. Failures ensue.

Version-Release number of selected component (if applicable):

redhat-rpm-config-8.0.45-14.fc7

How reproducible:

intrinsic

Steps to Reproduce:
1. try to build, for example, a jpackage.org nosrc rpm
2. watch it not work.
3. there is no step three.
  
Actual results:

it fails with an error message about a temporary directory not existing.

Expected results:

it shouldn't be looking there anyway

Additional info:

replace all instances of TMPDIR in this script with something like JTMPDIR and
the problem is solved

-- Additional comment from mattdm@mattdm.org on 2007-06-11 16:01 EST --
This is still a problem in current Fedora Rawhide (pre-f8, at this point), and
in RHEL5. It's an easy fix -- please make it.

-- Additional comment from katzj@redhat.com on 2007-06-19 14:17 EST --
Push will be fixed for rawhide later today  

-- Additional comment from mattdm@mattdm.org on 2007-06-19 14:19 EST --
Thanks man. 

-- Additional comment from mattdm@mattdm.org on 2007-06-19 14:28 EST --
Also, this probably deserves to get put in an update for RHEL5 eventually.
Comment 8 errata-xmlrpc 2008-05-21 12:51:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0470.html
Comment 9 Chris Ward 2008-06-17 11:48:50 EDT
Reminder: This bug includes the 'RHTS' QA Whiteboard Keyword. Don't forget to add
'RHTSdone' to the QA Whiteboard along with a comment describing where the RHTS
test can be found once the RHTS test has been written. Otherwise, if an RHTS
will not be created, please remove RHTS from the qa whiteboard.

Note You need to log in before you can comment on or make changes to this bug.