Bug 244930 - kmail: Filtering on imap accounts is broken
kmail: Filtering on imap accounts is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 17:32 EDT by Sebastian Vahl
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.5.7-10.svn20070926.ent.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
fedora: fedora_requires_release_note+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 126182 None None None Never

  None (edit)
Description Sebastian Vahl 2007-06-19 17:32:40 EDT
Description of problem:
Automatically filtering on imap accounts mostly only works for the first mail. 
All mails after the first one would not be filtered. 
Manual filtering only works for 1-3 mails at once. All mails after them are 
crossed-out but not filtered.



Version-Release number of selected component (if applicable):
kdepim-3.5.7-0.1.fc7

How reproducible:
everytime

Steps to Reproduce:
1. Have multiple mails on an imap account
2. Try to apply filters manually to more than 3 mails

or

1. Have multiple mails on an imap account
2. Receive more than 1 mail on this account which would be filtered
  
Actual results:
Only the first mail would be filtered.


Expected results:
The filters would be applied to all mails

Additional info:
This seems to be a known upstream bug newly introduced in kdepim-3.5.7:
http://bugs.kde.org/show_bug.cgi?id=126182

A reverted patch would maybe fix this: 
http://bugs.kde.org/show_bug.cgi?id=126182#c23

After a downgrade to kdepim-3.5.6 filtering works fine.
Comment 1 Kevin Kofler 2007-06-19 19:37:17 EDT
Unfortunately, reverting the patch might not be enough:

------- Additional Comment #24 From Alexey Morozov 2007-06-04 14:41 -------  
Just noticed: 
 
KMail with reverted r650963 applies filters to the new messages, except those 
which just arrived: that is if KMail receives a new message or messages they 
won't be processed during this transaction, only in the next check cycle. 
 
Does anybody actually understand how KMail filters are processed? 
 
 
------- Additional Comment #25 From Alexey Morozov 2007-06-05 07:24 -------  
I have to conclude: filter processing is seriously broken in KMail :-(. 
 
Now I have a simple filter (actually it's a default anti-spam filter which 
checks for X-Spam-Flag == YES and moves the message to trash). The header check 
simply doesn't work, although similar checks perfectly work in other 
filters :-( 
 
Could anybody explain how they are expected to work, step by step? 
Comment 2 Kevin Kofler 2007-07-13 02:47:04 EDT
Do we have any solution to this yet? We should really fix this regression 
sooner rather than later.
Comment 3 Rex Dieter 2007-07-20 08:21:39 EDT
It's pretty much out of our hands (waiting on upstream), unless somebody 'round
here turns into a kdepim dev/hacker.
Comment 4 Sebastian Vahl 2007-10-06 03:54:11 EDT
Uh. Just forgotten. kdepim-3.5.7-9.svn20070926.ent.fc8 (the enterprise branch) 
fixes the imap problem.
Comment 5 Garry T. Williams 2007-10-08 18:35:43 EDT
I can confirm the fix: kdepim-3.5.7-9.svn20070926.ent.fc8 restores IMAP inbox
filtering.  (I installed this on a F7 system from the fedora-development
repository.)
Comment 6 Fedora Update System 2007-10-10 21:44:18 EDT
kdepim-3.5.7-10.svn20070926.ent.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepim'
Comment 7 Sebastian Vahl 2007-10-11 16:37:53 EDT
Added "fedora_requires_release_note" "+"

We're using the more stable kdepim-enterprise for Fedora 8 (and also Fedora 7 
as an update).
Comment 8 Fedora Update System 2007-10-24 03:03:00 EDT
kdepim-3.5.7-10.svn20070926.ent.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.