Bug 244963 - xinput.sh should be moved to im-chooser
Summary: xinput.sh should be moved to im-chooser
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 06:18 UTC by Jens Petersen
Modified: 2014-06-18 09:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 21:13:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2007-06-20 06:18:22 UTC
Description of problem:
This is to propose that the xinput.sh script which starts up 
Input Methods at X startup should be moved to im-chooser - 
the tool that configures Input Method usage on the desktop.
There is no point really to run xinput.sh when there are no input methods
installed in the system and having it maintained in the same
package where users can configure it makes more sense also from the
maintenance point of view.  All input method packages should
require im-chooser and it is currently installed by default.

Comment 1 Akira TAGOH 2007-06-20 11:35:51 UTC
For another point, since im-chooser depends on the behavior of what xinput.sh
does, like to detect which IM are used for the language etc. so it makes sense
to move xinput.sh to im-chooser.

Comment 2 Jens Petersen 2007-07-17 06:19:12 UTC
ping

Comment 3 Søren Sandmann Pedersen 2007-07-24 18:05:26 UTC
Makes sense to me.

Feel free to move it.

Comment 4 Akira TAGOH 2007-07-25 04:47:03 UTC
Hmm, unfortunately we can't do that due to the acl. could you please quickly
update the package without xinput.sh?


Comment 5 Søren Sandmann Pedersen 2007-07-27 21:13:28 UTC
Fixed in xorg-x11-xinit-1.0.2-22.fc8.


Note You need to log in before you can comment on or make changes to this bug.