Bug 24502 - RH 7.0 Hangs on boot just after installation
RH 7.0 Hangs on boot just after installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-21 08:22 EST by Need Real Name
Modified: 2007-03-26 23:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-21 08:22:24 EST
After the message that goes something like "Turning on user and group 
quotas etc etc etc: [OK]" the system hangs.  At first my system was 
hanging randomly either after that message or after "Enabling swap 
space".  I found another bug report on this site regarding the latter and 
made the changes instructed to the rc.sysinit file (commenting out lines 
583-585 regarding agpgart).  This did not fix the problem.  It now always 
hangs on the first message i mentioned however.  I edited rc.sysinit by 
adding in lines like echo "1", echo "2", etc interleaving the lines in the 
script to form a trace and found that it is hanging in the section 
commented "Cleaning up utmp/wtmp".  More specifically on the line that 
says "touch /var/log/wtmp".  I tried removing this line and rebooting and 
it just hung on the next line.   I tried commenting out the entire section 
and it still hung.  This does not appear to be a duplicate of the agpgart 
bug.  I am running on a Toshiba SatellitePro 4270ZDVD (exactly the same as 
at www.toshiba.ca under SatellitePro 4260 except with a Celeron 500 CPU 
and a 15" screen instead of 14.1").  Any help would be greatly appreciated.
Comment 1 David Tonhofer 2001-01-22 13:13:16 EST
Probably of not much help but I had a similar problem of random hangups during
boot in 6.2 (at a later stage, though, while starting the services. It would
just say 'Starting syslogd...' and then -- nothing). Eventually I got so fed up 
that I replaced the motherboard and...the thing ran smoothly after that.
Comment 2 Need Real Name 2001-01-22 23:42:44 EST
I have figured out what the problem is.  It seems that on the Toshiba 
SatellitePro 4270ZDVD Laptop computer the sound module hangs the system when 
loaded.  I removed the sound line from the modules.conf file and everything 
works.  As for WHY it hangs the system I have no idea.

for anyone debugging the sound module (if there needs to be debugging done in 
the code)... the specs can be found at http://www.toshiba.ca/ISG/html/body_pr-
feb_17_00.html or elsewhere on www.toshiba.ca


Note You need to log in before you can comment on or make changes to this bug.