Bug 245037 - Dell Latitude D620 won't resume from suspend
Dell Latitude D620 won't resume from suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 13:28 EDT by Matt McCutchen
Modified: 2015-03-04 20:18 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.1-27.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 21:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt McCutchen 2007-06-20 13:28:30 EDT
Description of problem:
My Dell Latitude D620 laptop won't resume from suspend mode.  When I press the
power button to resume it, the display remains off.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3228.fc7
pm-utils-0.99.3-6.fc7

How reproducible:
Always

Steps to Reproduce:
1. Panel menu: System -> Suspend.
2. Press the computer's power button.
  
Actual results:
The display remains blank with the backlight off.  The power light is on, the
hard disk light comes on once for a second or two, and the Bluetooth light
flashes continuously (even though I have disabled Bluetooth in the BIOS).

Expected results:
The display comes on and shows the gnome-screensaver password prompt so I can
unlock the screen and continue working.

Additional info:
- I am using iwl3945, but I set SUSPEND_MODULES="iwl3945 mac80211" in
/etc/pm/config.d/unload_modules , and I get a message about iwl3945 being
unloaded when I suspend.  The same behavior happened with the ipw3945 driver.
- Resume worked fine on FC6 kernels with the ipw3945 driver.
- I recently unset my system password in the BIOS.  Before I unset the password,
the behavior on resume was as follows: the BIOS password prompt appears, I enter
the password, and then the display shows the four yellow letters "Linu" in the
top row of the screen on a black background.
Comment 1 Manmathan Kumarathurai 2007-07-16 11:14:22 EDT
I have the same problem
Comment 2 Matt McCutchen 2007-07-16 13:56:47 EDT
Manmathan, what model of computer and versions of software are you using?
Comment 3 Matt McCutchen 2007-07-23 21:36:04 EDT
I tried the recently released kernel-2.6.22.1-27.fc7 and the problem went away.
 Thus, I conclude that the bug was in kernel-2.6.21-1.3228.fc7; I'm changing the
component accordingly.  Alas, I can't use the new kernel because it does not
recognize my wireless card, which is a more serious problem for which I will
file a separate bug.

Manmathan, if you see the problem again with kernel-2.6.22.1-27.fc7, please
comment and I will reopen the bug.
Comment 4 Matt McCutchen 2007-07-23 21:52:26 EDT
(In reply to comment #3)
> Alas, I can't use the new kernel because it does not
> recognize my wireless card, which is a more serious problem for which I will
> file a separate bug.

Never mind, bug 249253 purports to solve this.

Note You need to log in before you can comment on or make changes to this bug.