Bug 245044 - Review Request: Parrot - A VM for Dynamic Languages
Summary: Review Request: Parrot - A VM for Dynamic Languages
Status: CLOSED DUPLICATE of bug 246348
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jochen Schmitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 17:51 UTC by David Fetter
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-30 19:32:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Fetter 2007-06-20 17:51:31 UTC
Spec URL: http://fetter.org/rpm/parrot.spec
SRPM URL: http://fetter.org/rpm/parrot-0.4.13-1.fc7.src.rpm
Description: Parrot is a virtual machine designed to efficiently compile and execute bytecode for dynamic languages. Parrot currently hosts a variety of language implementations in various stages of completion, including Tcl, Javascript, Ruby, Lua, Scheme, PHP, Python, Perl 6, APL, and a .NET bytecode translator.

Comment 1 Jochen Schmitt 2007-06-20 18:42:05 UTC
Trouble to access SPEC file:

Forbidden

You don't have permission to access /rpm/parrot.spec on this server.
Apache/2.2.4 (Fedora) Server at fetter.org Port 80

Comment 2 David Fetter 2007-06-20 18:47:04 UTC
Oops.  Fixed :)

Comment 3 Jochen Schmitt 2007-06-21 16:50:34 UTC
Good:
+ Naming seems ok.
+ Package contains the most recent upstream version.
+ Tab ball matches with upstream.
+ License seems ok (Artistic 2.0)
+ Local build works fine.

Bad:
+ Rpmlint show following warnings for the source RPM:
W: parrot invalid-license Artistic 2.0
W: parrot strange-permission parrot.spec 0600
- Devel package contains static library
- Requires %{_libdir}/pkgconfig should changes into pkgconfig
- Package should contains BR flex and byacc
- A log of error from rpmlint on the binary RPM:
W: parrot invalid-license Artistic 2.0
W: parrot strange-permission parrot.spec 0600
- Mock build fails:
Parrot Version 0.4.13 Configure 2.0
Copyright (C) 2001-2007, The Perl Foundation.

Hello, I'm Configure. My job is to poke and prod your system to figure out
how to build Parrot. The process is completely automated, unless you passed in
the `--ask' flag on the command line, in which case it'll prompt you for a few
pieces of info.

Since you're running this program, you obviously have Perl 5--I'll be pulling
some defaults from its configuration.
Can't locate ExtUtils/Manifest.pm in @INC (@INC contains: lib config
/usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at config/init/manifest.pm line 23.
BEGIN failed--compilation aborted at config/init/manifest.pm line 23.
Compilation failed in require at (eval 2) line 1.
BEGIN failed--compilation aborted at (eval 2) line 1.
error: Bad exit status from /var/tmp/rpm-tmp.5677 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.5677 (%build)











Comment 4 Steven Pritchard 2007-06-30 19:32:08 UTC
I'm going to take over submission of this package, so I've opened a new bug.

*** This bug has been marked as a duplicate of 246348 ***


Note You need to log in before you can comment on or make changes to this bug.