Bug 245072 - system-config-users hangs when adding group
Summary: system-config-users hangs when adding group
Status: CLOSED DUPLICATE of bug 238992
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-users (Show other bugs)
(Show other bugs)
Version: 4.4
Hardware: i686 Linux
low
medium
Target Milestone: ---
: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
: 245073 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 20:24 UTC by David Parker
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 12:53:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Parker 2007-06-20 20:24:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 1.0.3705; .NET CLR 2.0.50727)

Description of problem:
When attempting to add a group in system-config-users, the screen hangs and the following messages are displayed on the term screen that launched app:

Traceback (most recent call last):
  File "/usr/share/system-config-users/groupWindow.py", line 94, in on_groupWin_ok_button_clicked
    if not userGroupCheck.isGroupnameOk(groupName, self.groupWinGroupName):
  File "/usr/share/system-config-users/userGroupCheck.py", line 121, in isGroupnameOk
    return isUserGroupNameOk ('group', name, widget)
NameError: global name 'name' is not defined


Version-Release number of selected component (if applicable):
system-config-users-1.2.27-0.EL4.4

How reproducible:
Always


Steps to Reproduce:
1.Login with putty. Make sure to start local xserver (Hummingbird eXceed)
2.Launch system-config-users
3.Add group icon. Fill in group and gid. Click OK

Actual Results:
application hangs. Group not added. Errors displayed on terminal

Expected Results:
Group should be added to /etc/group

Additional info:

Comment 1 Nils Philippsen 2007-06-21 10:14:38 UTC
*** Bug 245073 has been marked as a duplicate of this bug. ***

Comment 2 Nils Philippsen 2007-06-21 12:53:10 UTC

*** This bug has been marked as a duplicate of 238992 ***


Note You need to log in before you can comment on or make changes to this bug.