Bug 245079 - No virtual desktop.
Summary: No virtual desktop.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 21:44 UTC by Bob T.
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-29 20:21:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.63 KB, text/plain)
2007-06-20 21:44 UTC, Bob T.
no flags Details
Xorg.0.log (40.73 KB, text/plain)
2007-06-20 21:45 UTC, Bob T.
no flags Details

Description Bob T. 2007-06-20 21:44:32 UTC
Description of problem:

No virtual display with F7.

Version-Release number of selected component (if applicable):

2.0.0-4


How reproducible:

Never fails.


Steps to Reproduce:
1. start X
2.
3.
  
Actual results:

Despite Virtual 1600 1350 in xorg.conf, the display is 1024x768




Expected results:

Virtual display of 1600x1350.

Additional info:

Comment 1 Bob T. 2007-06-20 21:44:32 UTC
Created attachment 157500 [details]
xorg.conf

Comment 2 Bob T. 2007-06-20 21:45:38 UTC
Created attachment 157501 [details]
Xorg.0.log

Comment 3 Bob T. 2007-06-20 21:47:30 UTC
I should have added that the virtual display worked with FC6 (and earlier).

Comment 4 Bob T. 2007-06-24 19:01:45 UTC
I've reverted to xorg-x11-drv-i810-1.6.5-10.fc6 and the virtual desktop works
fine. So there does seem to be an issue with 2.0.0-4. Changing severity to medium.

Comment 5 Bob T. 2007-06-29 20:21:12 UTC
It turns out this is not a bug but a feature of recent X drivers.  Essentially,
the xorg folks have decided to get rid of VIRTUAL at the driver level.  If you
want virtual desktops back,  please add a comment
supporting the following enhancement request:

https://bugs.freedesktop.org/show_bug.cgi?id=11418

The request is for adding a hook to the X-server code that will allow
window managers and "desktops" to implement virtual desktops easily.


Note You need to log in before you can comment on or make changes to this bug.