Bug 245086 - add Provides: hg to mercurial
Summary: add Provides: hg to mercurial
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-20 23:06 UTC by Seth Vidal
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-01 15:00:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Seth Vidal 2007-06-20 23:06:02 UTC
Description of problem:
I keep forgetting that hg == mercurial

yum will install-by-provides

so if you would add:
Provides: hg

to your package then I could do:

yum install hg and it would dtrt, rather than now where it tells me it has
nothing to do. :(

I'll happily make this edit for you, I just didn't want to step on toes.

Comment 1 Seth Vidal 2007-06-21 02:38:21 UTC
done in cvs on f-7 and devel

Comment 2 Ville Skyttä 2007-06-21 06:39:46 UTC
Please make it versioned, like "Provides: hg = %{version}-%{release}".

Comment 3 Seth Vidal 2007-06-21 06:44:44 UTC
why? What does it matter if it is versioned or not for this kind of provide?

Comment 4 Ville Skyttä 2007-06-21 06:48:37 UTC
What kind of provide?  Why wouldn't it matter?  Why wouldn't we want every
Provides that has a natural version to be versioned in packages too?

Comment 5 Seth Vidal 2007-07-01 15:00:22 UTC
fair enough -added - sorry for the long delay.



Note You need to log in before you can comment on or make changes to this bug.