Bug 245099 - incomplete domU save file when domain-0 reboot
incomplete domU save file when domain-0 reboot
Status: CLOSED DUPLICATE of bug 214995
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 22:23 EDT by Wesly Chen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 08:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/xen/xend.log (242.37 KB, text/plain)
2007-06-20 23:08 EDT, Wesly Chen
no flags Details
/var/log/xen/xend-debug.log (648 bytes, application/octet-stream)
2007-06-20 23:09 EDT, Wesly Chen
no flags Details
bash -x /etc/init.d/xendomains start (with /var/lib/xen/save/rhel3_32) (2.45 KB, application/octet-stream)
2007-06-20 23:14 EDT, Wesly Chen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1572386 None None None Never

  None (edit)
Description Wesly Chen 2007-06-20 22:23:16 EDT
Description of problem:
When domain-0 is rebooted without shutting down the domU gracefully, it creates 
an incomplete save file in /var/lib/xen/save/<domU name>, and you can not start 
that domU anymore unless you remove /var/lib/xen/save/<domU name>

Version-Release number of selected component (if applicable):
xen-3.0.3-25.0.3.el5.x86_64

How reproducible:
easy

Steps to Reproduce:
1. create a runable domU, say rhel3_32
2. xm create rhel3_32
3. reboot domain-0 (host) machine without shutting down rhel3_32
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2007-06-20 22:32:11 EDT
Please provide the guest config file and  /var/log/xen/xend.log and
/var/log/xen/xend-debug.log
Comment 2 Wesly Chen 2007-06-20 23:08:41 EDT
Created attachment 157509 [details]
/var/log/xen/xend.log
Comment 3 Wesly Chen 2007-06-20 23:09:37 EDT
Created attachment 157510 [details]
/var/log/xen/xend-debug.log
Comment 4 Wesly Chen 2007-06-20 23:12:17 EDT
Please trace back the time stamp before 17:30 June 20 in the log. Because I have
remove the /var/lib/xen/save/rhel3_32 before reboot after 17:30 June 20.
Comment 5 Wesly Chen 2007-06-20 23:14:15 EDT
Created attachment 157511 [details]
bash -x /etc/init.d/xendomains start (with /var/lib/xen/save/rhel3_32)
Comment 6 Daniel Berrange 2007-06-21 08:43:21 EDT
The xend.log file shows that  rhel3_32  is a fully virtualized guest. Save and
restore does not work for fullvirtualized guests in Xen 3.0.3.

*** This bug has been marked as a duplicate of 214995 ***
Comment 7 Wesly Chen 2007-06-21 12:29:33 EDT
OK.
If fully virtualized guest is not supported in in Xen 3.0.3, then it should not
save the fully-virtualized domU when the dom0 reboot.
It should destroy the fully-virtualized domU to avoid restoring issue, shouldn't it?
Otherwise, when dom0 crashes or power outage, all the fully-virtualized domUs
will have the issue to bring on up.

Note You need to log in before you can comment on or make changes to this bug.