Bug 245104 - openjade always segfaults when run
Summary: openjade always segfaults when run
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: opensp   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-21 04:59 UTC by Bryan O'Sullivan
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 1.5.2-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 15:24:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan O'Sullivan 2007-06-21 04:59:50 UTC
Description of problem:

Run openjade on any file.  It immediately crashes.

Version-Release number of selected component (if applicable):

openjade-1.3.2-28.fc7
opensp-1.5.2-4.fc7

How reproducible:

100%

Backtrace:

Looks like opensp is implicated.

(gdb) bt
#0  0x00000031fc8f684d in OpenSP::ParsedSystemId::unparse ()
   from /usr/lib64/libosp.so.5
#1  0x00000031fdd3d071 in OpenJade_DSSSL::DssslApp::processSysid ()
   from /usr/lib64/libostyle.so.0
#2  0x00000031fc8e9b10 in OpenSP::EntityApp::processArguments ()
   from /usr/lib64/libosp.so.5
#3  0x00000031fc8d769f in OpenSP::CmdLineApp::run ()
   from /usr/lib64/libosp.so.5
#4  0x0000000000411865 in OpenJade_DSSSL::FOTBuilder::setFontSize ()

Comment 1 Ondrej Vasik 2007-06-21 12:29:05 UTC
Correct, found problem in OpenSP , changing Component line to OpenSP. I'm
working on the problem. Problem is occuring in all versions of Fedora using
1.5.2 openSP from upstream.

Comment 2 Ondrej Vasik 2007-06-21 13:15:36 UTC
Fix of segmentation fault in opensp checked and patch commited. Closing RAWHIDE.

Comment 3 Bryan O'Sullivan 2007-06-21 14:29:11 UTC
Thanks.  Does this mean you won't be pushing out an update for F7?

Comment 4 Ondrej Vasik 2007-06-21 14:44:17 UTC
It is pushed for FC-6 and F-7, but it could take some time till it will get to
updates, in devel you can already get it.

Comment 5 Fedora Update System 2007-06-25 23:22:22 UTC
opensp-1.5.2-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-07-11 15:24:54 UTC
opensp-1.5.2-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.