Bug 245121 - Use CangJie3 instead of CangJie as the default input method zh_HK
Use CangJie3 instead of CangJie as the default input method zh_HK
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 05:33 EDT by Roy Chan
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 21:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy Chan 2007-06-21 05:33:46 EDT
Description of problem:
Fedora 7 use CangJie (倉頡大字集) as the default input method for zh_HK (Hong
Kong locale) which confuse most CangJie user in Hong Kong. The CangJie table of
SCIM is based on CMEX CangJie table of Taiwan. It support over 70,000 chinese
characters including traditional chinese and simplified chinese (and even
Japanese chinese). But it is based on taiwan chinese glyph the CangJie input
code and have many different with the CangJie in Microsoft Windows system.
Common user will be frastrated fail to input the charater with the traditional
cangjie code they use in past and Windows system.

There are another two cangjie input methods - CangJie3  (倉頡第三代) and
CangJie5 (倉頡第五代) in SCIM-tables. And CangJie3 is most similar to the
CangJie in Windows system. But they are NOT  enable by default on a new
installed Fedora 7 system.

Although people can change it with the SCIM setup, it is inconvenience for new
user who shift. And might make people think Fedora/SCIM provide only unusable
CangJie input method.

Version-Release number of selected component (if applicable):
scim 1.4.5

How reproducible:


Steps to Reproduce:
1. Install the Fedora 7 with the DVD installation and choose Chinese
(Traditional) as language
2. Click the SCIM applet on the GNOME notification area of the new Fedora 7
system will list only CangJie (倉頡大字集). While there is another 2 cangjie
input methods -  CangJie3  (倉頡第三代) and CangJie5 (倉頡第五代) in SCIM-tables
  
Actual results:
It is recommend to use CangJie3 (倉頡第三代) instead of CangJie (倉頡大字集) as
the default
input method. Because CangJie3 provide the most similar input code and user
experience as the CangJie input method in Windows system


Expected results:
Use CangJie3 instead of CangJie as the default input method of zh_HK


Additional info:
Comment 1 Caius Chance 2007-06-21 20:15:12 EDT
Hi,

Should we make a button on toolbars or some choosers for fast switching among
all Changjie (orig, 3, 5) IMEs? I guess normal user are not very clear about the
differences between those Changjie IMEs.

Though Changjie 3 is most compatiable to Windows, should we rethink that if
user's freedom of typing with a enhanced and improved IME (Changjie 5) is more
important? Just by our single decision, all Fedora users' experience will be
trapped in old Changjie 3 age solely because of Microsoft still having a
outdated  IME.

However, anyways no matter having Changjie 3 or 5, we should avoid using
Changjie original.

Thank you very much. Please feel free to discuss further.

- Caius
Comment 2 Caius Chance 2007-06-21 20:20:21 EDT
(more like a enhancement, moved to devel tree)
Comment 3 Jens Petersen 2007-06-21 21:42:42 EDT
Ok I am making Cangjie3 the default in scim-1.4.6-6.fc8 and disabling the old
Cangjie instead of the newer Cangjie3 and Cangjie5 by default.

Thank you very much for the feedback. :)

Next time I update scim for F7 I will probably backport the changes there also.

Note You need to log in before you can comment on or make changes to this bug.