Bug 245141 - glibmm24, gtkmm24 have to be rebuilt against newest GLIb??
Summary: glibmm24, gtkmm24 have to be rebuilt against newest GLIb??
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibmm24   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-21 11:35 UTC by Mamoru TASAKA
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 18:52:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build log of gtkmm24 on Fedora devel i386 (48.83 KB, text/plain)
2007-06-21 11:35 UTC, Mamoru TASAKA
no flags Details
mock build log of gtkmm24 after glibmm24 rebuilt (960.76 KB, text/plain)
2007-06-21 11:38 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2007-06-21 11:35:15 UTC
Description of problem:
Well, currently I maintain jd, which heavily uses
glibmm24 and gtkmm24.

When I upgraded glib2 to 2.13.5-1.fc8, jd stopped to be
rebuilt. However, when I rebuilt glibmm24 -> gtkmm24 with mockbuild
against newest glib2, jd came to be rebuilt again.

Also, currently gtkmm24 cannot be rebuilt with mockbuild
on Fedora devel. However once I rebuild glibmm24 against newest
glib2, gtkmm24 can be rebuilt again.

Version-Release number of selected component (if applicable):
glib2-2.13.5-1.fc8
glibmm24-2.12.8-1.fc7
gtkmm24-2.10.9-1.fc7
jd-1.9.5-0.5.beta070616.fc8

How reproducible:
100% for me (Fedora devel i386)


Steps to Reproduce:
1. Try to rebuild gtkmm24 with mockbuild
2.
3.
  
Actual results:
Attached (mysterious failure)

Comment 1 Mamoru TASAKA 2007-06-21 11:35:15 UTC
Created attachment 157527 [details]
mock build log of gtkmm24 on Fedora devel i386

Comment 2 Denis Leroy 2007-06-21 11:36:53 UTC
I know, rawhide moved to gtk 2.13, so i have to update gtkmm and al to the
unstable 2.13 versions. Will do this shortly.


Comment 3 Mamoru TASAKA 2007-06-21 11:38:32 UTC
Created attachment 157528 [details]
mock build log of gtkmm24 after glibmm24 rebuilt

After glibmm24 is rebuilt against newest glib2, again
gtkmm24 succeeds to be rebuilt.

Comment 4 Mamoru TASAKA 2007-06-27 07:16:11 UTC
closing, thank you.

Comment 5 Mamoru TASAKA 2007-06-30 04:29:06 UTC
Well, glib2 is updated to 2.13.6 and again jd cannot be rebuilt
like:
--------------------------------------------------------
winmain.o: In function
`Glib::PropertyProxy<Gtk::WindowPosition>::set_value(Gtk::WindowPosition const&)':
/usr/include/glibmm-2.4/glibmm/propertyproxy.h:132: undefined reference to
`Glib::ValueBase::init(unsigned long)'
---------------------------------------------------------
It seems that glibmm24 and gtkmm24 have to be rebuilt against
newest glib2 again.

Is this related to bug 245634?

Comment 7 Denis Leroy 2007-07-02 10:39:41 UTC
Yes, this is very much caused by bug 245634. I'm on vacation until July 8th, so
I won't have time to fix this until then. OTOH, i don't think there is ACL
access for glibmm/gtkmm so feel free to do the release bumps and releases
yourself, or ask to be made a co-maintainer (use this bugzilla entry as proof of
my agreement :-) ).

Comment 8 Mamoru TASAKA 2007-07-02 15:21:28 UTC
Well, actually glibmm24 and gtkmm24 have no acl restriction and
it seems that only you are the maintainer of both.

So I will try to rebuild both now.

Comment 9 Mamoru TASAKA 2007-07-02 18:52:22 UTC
Okay, now I rebuilt both glibmm24, gtkmm24 and then jd, all
succeeded. And jd rebuilt on F-7 system works on Fedora devel,
so I guess ABI breakage is now fixed.

Closing again. Thank you.


Note You need to log in before you can comment on or make changes to this bug.