Bug 245146 - Attribute error in orca/atspi.py
Attribute error in orca/atspi.py
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: orca (Show other bugs)
5.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 08:11 EDT by Alexander Todorov
Modified: 2014-09-01 07:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2007-06-21 08:11:42 EDT
Description of problem:
When you run /usr/lib64/python2.4/site-packages/orca/atspi.py it generates an
error. The file is supposed to be self testing.

Version-Release number of selected component (if applicable):
orca-1.0.0-5.el5

How reproducible:
always

Steps to Reproduce:
1. python /usr/lib64/python2.4/site-packages/orca/atspi.py
  
Actual results:
GTK Accessibility Module initialized
There are 1 desktops
  Desktop 0 (name=main) has 18 apps
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/orca/atspi.py", line 1439, in ?
    __test()
  File "/usr/lib64/python2.4/site-packages/orca/atspi.py", line 1428, in __test
    __printDesktops()
  File "/usr/lib64/python2.4/site-packages/orca/atspi.py", line 1351, in
__printDesktops
    print "    App %d: name=%s role=%s" \
AttributeError: 'Application' object has no attribute 'role'

Expected results:
The application should not crash with error and print some info about the desktop.
Comment 1 RHEL Product and Program Management 2008-07-21 19:10:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2011-05-31 10:36:25 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2014-03-07 08:43:55 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 6 RHEL Product and Program Management 2014-06-02 09:18:17 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.