Bug 24517 - Inconsistencies in a documentation layout
Inconsistencies in a documentation layout
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-21 16:00 EST by Michal Jaegermann
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-21 16:00:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-01-21 16:00:07 EST
A content of directories /usr/share/doc/samba-2.0.7/docs/htmldocs
and /usr/share/swat/help is nearly identical but not quite.  One would
think that at least identical documents should be replaced in one
place by links to ensure consistency.

Also /usr/share/swat/using_samba/ smells to me like a documentation
but it is not in /usr/share/doc tree.  It is probably where it is because
swat will serve its content on line when swat is used.  At least a link to
it should be provided somewhere in /usr/share/doc/samba*/ or somebody
not running swat may easily miss it.  Note that by default swat is off.

  Michal
  michal@harddata.com
Comment 1 Bill Nottingham 2001-01-31 17:22:39 EST
This is not exactly feasible.

- the docs in /usr/share/doc/samba-2.0.7 are in the samba package
- swat is a separate subpackage

You can't have the files in swat be symlinks, because the packages might have
been installed with --excludedocs. And you can't have the docs be symlinks,
because swat might not be installed at all.

Note You need to log in before you can comment on or make changes to this bug.