Bug 245181 - config doesn't allow paths with spaces
config doesn't allow paths with spaces
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 10:34 EDT by Ted X Toth
Modified: 2008-04-04 10:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 10:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (8.97 KB, patch)
2007-06-21 10:34 EDT, Ted X Toth
no flags Details | Diff

  None (edit)
Description Ted X Toth 2007-06-21 10:34:28 EDT
Description of problem:
pam_namespace cannot polyinstantiate directories that have spaces in their name.
The configuration file processing code uses strtok_r with delimiters space and
tab. There is no functionality to allow escaping of spaces or quoting of strings
so that paths with spaces can be specified.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I utilized a small piece of open source code (argv_parse) to parse the config
file lines because I'd basically have to do something like this to fix the code
anyway and this was eaiser.
Comment 1 Ted X Toth 2007-06-21 10:34:28 EDT
Created attachment 157542 [details]
patch
Comment 2 Tomas Mraz 2008-04-04 10:17:29 EDT
This bug is resolved in Linux-PAM 1.0 which will be included in the next release
of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.