Bug 245183 - GFS2 - invalid metadata block, function = get_leaf, file = fs/gfs2/dir.c , line = 701
GFS2 - invalid metadata block, function = get_leaf, file = fs/gfs2/dir.c , l...
Status: CLOSED DUPLICATE of bug 248176
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Robert Peterson
Dean Jansa
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 10:52 EDT by Abhijith Das
Modified: 2009-05-27 23:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 15:05:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijith Das 2007-06-21 10:52:41 EDT
Description of problem:
I hit this corruption while running revolver on the smoke cluster. It is running
the latest bits (kernel and GFS2) from Steve's nmw git tree.

GFS2: fsid=Smoke_Cluster:gfs2.1.2: fatal: invalid metadata block
GFS2: fsid=Smoke_Cluster:gfs2.1.2:   bh = 10774747 (magic number)
GFS2: fsid=Smoke_Cluster:gfs2.1.2:   function = get_leaf, file = fs/gfs2/dir.c,
line = 701
GFS2: fsid=Smoke_Cluster:gfs2.1.2: about to withdraw this file system
GFS2: fsid=Smoke_Cluster:gfs2.1.2: telling LM to withdraw
 [<c0104caf>] show_trace+0x12/0x14
 [<c0104d08>] dump_stack+0x16/0x18
 [<e0547a09>] gfs2_assert_withdraw_i+0x43/0x50 [gfs2]
 [<e053680e>] log_bmap+0xa6/0xe6 [gfs2]
 [<e0537177>] gfs2_log_fake_buf+0x19/0x115 [gfs2]
 [<e0537b1d>] buf_lo_before_commit+0x12a/0x17e [gfs2]
 [<e0536f7b>] gfs2_log_flush+0x119/0x2c7 [gfs2]
 [<e053f541>] gfs2_sync_fs+0x18/0x1c [gfs2]
 [<c0156475>] __fsync_super+0x42/0x5c
 [<c01700b3>] freeze_bdev+0x3c/0x6c
 [<c0381afe>] dm_suspend+0xf1/0x268
 [<c0384371>] dev_suspend+0x55/0x163
 [<c0384ccf>] ctl_ioctl+0x220/0x261
 [<c015e88f>] do_ioctl+0x8b/0xa3
 [<c015eaf0>] vfs_ioctl+0x249/0x25c
 [<c015eb34>] sys_ioctl+0x31/0x49
 [<c01032b2>] sysenter_past_esp+0x5f/0x85
 =======================
GFS2: fsid=Smoke_Cluster:gfs2.1.2: withdrawn
 [<c0104260>] show_trace_log_lvl+0x1a/0x2f
 [<c0104caf>] show_trace+0x12/0x14
 [<c0104d08>] dump_stack+0x16/0x18
 [<e0535f8a>] gfs2_lm_withdraw+0x81/0x8d [gfs2]
 [<e0547891>] gfs2_meta_check_ii+0x51/0x5e [gfs2]
 [<e052b6ee>] get_leaf+0x75/0xbd [gfs2]
 [<e052bcd8>] get_first_leaf+0x28/0x2f [gfs2]
 [<e052bd68>] gfs2_dirent_search+0x89/0x1a1 [gfs2]
 [<e052d45f>] gfs2_dir_search+0x21/0x6b [gfs2]
 [<e0534629>] gfs2_lookupi+0x11e/0x155 [gfs2]
 [<e053e7e1>] gfs2_lookup+0x1d/0x4d [gfs2]
 [<c015b9c1>] lookup_hash+0x83/0x9b
 [<c015d90c>] open_namei+0xe1/0x558
 [<c0153bca>] do_filp_open+0x26/0x3b
 [<c0153c22>] do_sys_open+0x43/0xc7
 [<c0153cde>] sys_open+0x1c/0x1e
 [<c01032b2>] sysenter_past_esp+0x5f/0x85
 =======================
Comment 1 Kiersten (Kerri) Anderson 2007-06-25 11:37:19 EDT
Blocking recovery tests at the moment, needs to be addressed prior to release.
Comment 2 RHEL Product and Program Management 2007-06-25 11:43:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Robert Peterson 2007-06-26 17:46:30 EDT
Abhi,

Can you recreate this and leave it in the failing state for me?
I want to see the cluster after a failure so I can examine the journals.
Comment 4 Steve Whitehouse 2007-07-16 06:12:34 EDT
Abhi, can you confirm that you never see this bug before at least one node has
completed recovery?
Comment 5 Robert Peterson 2007-07-23 15:05:03 EDT
This bug is the same as 248176.


*** This bug has been marked as a duplicate of 248176 ***

Note You need to log in before you can comment on or make changes to this bug.