Bug 245204 - OpenOffice Calc crashes when entering data
Summary: OpenOffice Calc crashes when entering data
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 6
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-21 16:44 UTC by ajs
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 14:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OpenOffice crash report (6.59 KB, text/plain)
2007-06-21 16:44 UTC, ajs
no flags Details
mapped backtrace (9.31 KB, text/plain)
2007-06-22 10:20 UTC, Caolan McNamara
no flags Details

Description ajs 2007-06-21 16:44:29 UTC
Description of problem:
When I try and enter data in Calc, it crashes

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.4-5.5.23

How reproducible:
always

Steps to Reproduce:
1. launch OpenOffice Calc
2. select a cell
3. hit a key
  
Actual results:
Crash.  See atachment

Expected results:


Additional info:
This started hapening sometime this week.  I updated Calc on the 13th, however.

Comment 1 ajs 2007-06-21 16:44:29 UTC
Created attachment 157555 [details]
OpenOffice crash report

Comment 2 Caolan McNamara 2007-06-21 17:47:39 UTC
I'm going to make a leap and assume that you have the testing update of cairo
1.4.8. If so, roll back to 1.4.4

*** This bug has been marked as a duplicate of 243811 ***

Comment 3 ajs 2007-06-21 19:17:12 UTC
I do not think that this is a duplicate.  When I set SAL_IGNOREXERRORS=YES calc
still crashes.

'rpm -q cairo' returns
cairo-1.2.6-1.fc6


Comment 4 Caolan McNamara 2007-06-21 20:53:47 UTC
ah yes, FC-6, it couldn't be the same problem. mea cupla

Comment 5 Caolan McNamara 2007-06-21 21:02:00 UTC
The trace would seem to imply that entering a key has triggered StarBasic into
action, which is sort of odd.

Comment 6 Caolan McNamara 2007-06-22 10:20:30 UTC
Created attachment 157605 [details]
mapped backtrace

Comment 7 Caolan McNamara 2007-06-22 10:58:13 UTC
Still very strange, I can't see why any of that would have crashed :-( I can but
only suggest that you reinstall office. 

e.g. 
rpm --erase `rpm -qf /usr/lib/openoffice.org2.0 | xargs` 
yum -y install openoffice.org-calc openoffice.org-writer openoffice.org-impress ...

Comment 8 ajs 2007-06-22 14:56:41 UTC
I did the reinstall.  I can now get work done again.

You mentioned StarBasic.  I have to share files with people who use MS office. 
Might a macro in one of these files caused the problem? 

Comment 9 Caolan McNamara 2007-06-22 15:02:29 UTC
I guess it's *possible* that there was a macro that activates on keystrokes, but
I would have expected to see something in the stack in-between the keystroke and
the construction of the StarBasic module, macros are probably a red-herring. If
it reoccurs and you have any suspicions as to what may have triggered it (e.g.
prelink runs daily to optimize newly installed binaries) then certainly let us know.


Note You need to log in before you can comment on or make changes to this bug.