This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 245205 - Feature request: add or remove devices
Feature request: add or remove devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On: 236800
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 13:00 EDT by Thomas Antony
Modified: 2008-01-22 11:03 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.3-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Antony 2007-06-21 13:00:12 EDT
Please add a option to virt-manager for add or remove devices like a cdrom, any
PCI or PCIe card or usb devices for each domain.
Comment 1 Daniel Berrange 2007-06-21 13:11:02 EDT
It is already possible to add/remove  harddisks and network devices.   CDROMs /
Floppy should be possible to add with very little work.

Adding  USB or Sound devices requires further support in libvirt, which is being
tracked/worked on upstream.

PCI device assignment is Xen specific capability that we don't plan to support
at this time - particularly since it is utterly insecure with all current hardware.
Comment 2 Fedora Update System 2008-01-11 17:26:41 EST
virt-manager-0.5.3-1.fc7, gtk-vnc-0.3.2-1.fc7, python-virtinst-0.300.2-1.fc7, virt-viewer-0.0.2-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager gtk-vnc python-virtinst virt-viewer'
Comment 3 Fedora Update System 2008-01-22 10:37:54 EST
virt-manager-0.5.3-1.fc7, gtk-vnc-0.3.2-1.fc7, python-virtinst-0.300.2-1.fc7, virt-viewer-0.0.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.