Bug 245208 - adminutil: Solaris port for 1.1
adminutil: Solaris port for 1.1
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.1.0beta
sparc Other
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-06-21 13:36 EDT by Rich Megginson
Modified: 2015-12-07 11:38 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:38:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (6.51 KB, patch)
2007-06-21 13:38 EDT, Rich Megginson
no flags Details | Diff
cvs commit log (1.85 KB, text/plain)
2007-06-21 17:29 EDT, Rich Megginson
no flags Details
cvs commit log - fix build breakage (1.28 KB, text/plain)
2007-06-21 19:06 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2007-06-21 13:36:36 EDT
There are several problems related to building and running adminutil on Solaris.
Comment 1 Rich Megginson 2007-06-21 13:38:50 EDT
Created attachment 157558 [details]
diffs
Comment 2 Nathan Kinder 2007-06-21 16:20:14 EDT
You don't need to include a dummy C++ source file in order to force libtool to
use CXXLINK.  The proper way to deal with this problem is to set "target_LINK =
$(CXXLINK)" in Makefile.am.  This forces it to use the C++ linked for building a
particular target, even if all the source files that make up that target are
pure C code.
Comment 3 Nathan Kinder 2007-06-21 16:21:39 EDT
Please disregard my previous comment.  I just noticed that the problem is that
CXXLINK is not defined at all if no C++ source files are listed in Makefile.am.
Comment 4 Rich Megginson 2007-06-21 17:29:40 EDT
Created attachment 157576 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Files: see diff - new file dummy.cpp
Branch: HEAD
Fix Description: There are several problems with building/running adminutil on
Solaris.  The biggest is that ICU introduces a dependency on C++.  Solaris
requires linking with the C++ libraries and that also requires using C++ to
link as well.  This means using the CXXLINK macro.  However, automake will only
generate this macro if it detects a C++ source file in Makefile.am.  So, we
have to introduce a dummy.cpp file to force automake to generate the CXXLINK
macro, then use that to link the shared libraries.
Accept automake version 1.10 or later.
Look for mozldap6 first, then mozldap.
Platforms tested: Solaris 9 64bit
Flag Day: Yes - autotool file changes
Comment 5 Rich Megginson 2007-06-21 19:06:24 EDT
Created attachment 157585 [details]
cvs commit log - fix build breakage

Fix linux build breakage - use $(LINK) if not using $(CXXLINK)
Comment 6 Anh Nguyen 2007-12-09 10:37:23 EST
to_be_verified_by_dev
Comment 7 Nathan Kinder 2007-12-17 14:06:18 EST
We have been successfully building and using adminutil on Solaris for some time
now.  Marking as verified.

Note You need to log in before you can comment on or make changes to this bug.