This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 245214 - adminserver: Solaris port for 1.1
adminserver: Solaris port for 1.1
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.1.0beta
sparc Other
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-06-21 14:10 EDT by Rich Megginson
Modified: 2015-12-07 11:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:59:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (17.36 KB, patch)
2007-06-21 14:10 EDT, Rich Megginson
no flags Details | Diff
cvs commit log (3.05 KB, text/plain)
2007-06-21 21:39 EDT, Rich Megginson
no flags Details
cvs commit log - fix build breakage (1.46 KB, text/plain)
2007-06-21 22:33 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2007-06-21 14:10:18 EDT
There are several problems related to building and running mod_admserv on Solaris.
Comment 1 Rich Megginson 2007-06-21 14:10:18 EDT
Created attachment 157561 [details]
diffs
Comment 2 Noriko Hosoi 2007-06-21 18:19:10 EDT
Your fixes look good.
Comment 3 Rich Megginson 2007-06-21 21:39:57 EDT
Created attachment 157589 [details]
cvs commit log

Reviewed by: nhosoi (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: Fortitude can supply different components, depending on the
operating system.  On Fedora, mod_nss and Apache are already there, so we don't
use Fortitude.
On RHEL4, we use Fortitude for mod_nss.
On Solaris, we use Fortitude for Apache and mod_nss.
I've created a fortitude.m4 that can handle all of these cases, and changed the
existing httpd.m4 and mod_nss.m4 to first see if fortitude.m4 has found the
component.  configure will also pass the proper --with flags to mod_admserv and
mod_restartd.
ICU introduces a dependency on C++.  Solaris requires linking with the C++
libraries and that also requires using C++ to link as well.  This means using
the CXXLINK macro.
There were a few other minor porting issues which required the additional
compiler defines and use of config.h.
We need to set the libpath before using the @cgibindir@/config program.
LIBPATH was not being set correctly on Solaris because I was using the extended
sort flags instead of the standard ones.
Platforms tested: Solaris 9 64bit
Flag Day: no
Doc impact: no
Comment 4 Rich Megginson 2007-06-21 22:33:36 EDT
Created attachment 157592 [details]
cvs commit log - fix build breakage

Fix Description: Fix build breakage involving CXXLINK and LINK
Comment 5 Nathan Kinder 2007-12-21 13:51:09 EST
We have been building and running adminserver on Solaris for quite some time
now.  Our Console automated tests have been testing the functionality.

Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.