Bug 245240 - Bootup ACPI kernel message not expected and may relate to failed wireless
Summary: Bootup ACPI kernel message not expected and may relate to failed wireless
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-21 20:28 UTC by Mike Cohler
Modified: 2015-01-04 22:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-23 16:37:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg attached (18.95 KB, text/plain)
2007-06-21 20:28 UTC, Mike Cohler
no flags Details
dmesg from boot on 18th Sept 2007 with latest kernel (17.93 KB, text/plain)
2007-09-18 08:22 UTC, Mike Cohler
no flags Details

Description Mike Cohler 2007-06-21 20:28:03 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:every time


Steps to Reproduce:
1. Boot machine
2. kernel message ACPI: count given by _CST is not valid
3. 
  
Actual results:ACPI: count given by _CST is not valid is on console and in dmesg


Expected results: This message should not be in the dmesg output


Additional info:Running F7 with kernel 2.6.21-1.3228.fc7

This message was there for previous kernels also, and in FC6

Just a hunch but I have been unable to get wireless running for a D-Link G650
cardbus card, and also unable to get a usb wireless dongle working - and it
looks like ACPI problems may cause some conflicts though I am not sure how to
test this.

The hardware profile is at
http://smolt.fedoraproject.org/show?UUID=5188ca05-a365-4fec-9b80-b6473622bd21

Copy of dmesg attached.

Comment 1 Mike Cohler 2007-06-21 20:28:03 UTC
Created attachment 157568 [details]
dmesg attached

Comment 2 Christopher Brown 2007-09-17 12:12:03 UTC
Hello Mike,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 3 Mike Cohler 2007-09-17 12:44:00 UTC
Hi Chris

In fact I had previously given up with trying to get wireless running with that
D-link card, but I did later manage to get the Edimax USB wireless dongle
working - though not with the builtin rt2x00 in the kernel. I downloaded one of
the nightly CVS tarballs for the rt73 usb driver and it worked.  The story does
continue though: after the most recent kernel update I downloaded the latest CVS
rt73 driver tarball and it would not work! So I recompiled one of the older
versions that did work previously and it does work with the latest F7 kernel.
The rt2x00 module in the current kernel also fails to work.

I will be away from that laptop until the coming weekend, but I will test the
G-650 card with the newest kernel on my return and report back after the weekend.

Mike


Comment 4 Mike Cohler 2007-09-18 08:20:38 UTC
I have managed to find a few minutes and get the laptop up  -  
Now running kernel 2.6.22.5-76.fc7
The boot message concerning "count given by _CST..." remains
I will attach the latest dmesg.
Since I have wireless running despite this message I guess this is not related
to wireless.
If there are any tests I can run to dig into this further please let me know,
but it will be the weekend before I can test further as I will be away from
tomorrow through Friday.

Comment 5 Mike Cohler 2007-09-18 08:22:00 UTC
Created attachment 198231 [details]
dmesg from boot on 18th Sept 2007 with latest kernel

Comment 6 Christopher Brown 2007-09-18 10:43:57 UTC
Hello Mike,

Yes the boot message is unrelated. Try booting with kernel parameter

acpi=off

and if this works then try 

nolapic

or

noapic

Essentially what appears to be happening is that a BIOS bug is not reporting the
correct number of power states available to the kernel ACPI implementation. You
may wish to see if there is a BIOS update available - is this a thinkpad?

Cheers
Chris

Comment 7 Mike Cohler 2007-09-18 11:01:34 UTC
OK I will try booting with these parameters when I get back to the laptop next
weekend.  It is a Fujitsu-Siemens Amilo D6800 and unfortunately not a Thinkpad.

Unfortunately there is no BIOS update available and I had already installed the
latest available.

I'll report back at the weekend.

Comment 8 Mike Cohler 2007-09-22 20:14:52 UTC
OK Chris, I have now tested -
1) With acpi=off it works and does not give the boot message.

2) With noapic the boot message is present.

3) With nolapic the boot message is also present.... 

If this is indeed a BIOS bug then I guess this is not fixable as this is a
machine which is now 4 years old and no bios update is available.

       BIOS Information
                Vendor: FUJITSU SIEMENS
                Version: V3.5 R01-F57  EN
                Release Date: 09/04/02
The machine is an Amilo D 6800 (Intel P4)

I just checked again that there are no newer BIOS updates.
However this is not a major problem and the machine does boot and run although
perhaps with less than optimum power efficiency.

If there is no further mileage in this bug then I guess it should be closed?

Mike

Comment 9 Christopher Brown 2007-09-23 16:37:16 UTC
(In reply to comment #8)
> OK Chris, I have now tested -
> 1) With acpi=off it works and does not give the boot message.
> 
> 2) With noapic the boot message is present.
> 
> 3) With nolapic the boot message is also present.... 
> 
> If this is indeed a BIOS bug then I guess this is not fixable as this is a
> machine which is now 4 years old and no bios update is available.
> 
>        BIOS Information
>                 Vendor: FUJITSU SIEMENS
>                 Version: V3.5 R01-F57  EN
>                 Release Date: 09/04/02
> The machine is an Amilo D 6800 (Intel P4)
> 
> I just checked again that there are no newer BIOS updates.
> However this is not a major problem and the machine does boot and run although
> perhaps with less than optimum power efficiency.
> 
> If there is no further mileage in this bug then I guess it should be closed?

A few things left to try yet Mike :)

Try with:

pci=noacpi
acpi=strict
acpi=noirq

which may enable acpi to a certain extent and give you some power savings. Since
your wireless is working though I think you can safely put this down to a
misbehaving BIOS and I'll close with the relevant indication of what worked for you.

Cheers
Chris

Comment 10 Mike Cohler 2007-09-24 20:25:22 UTC
OK one final set of results:

pci=noacpi  -  boot message remains
acpi=strict -  boot message remains
acpi=noirq  -  
"...error creating bridge symlink, continuing" on boot screen as well as the
previous message....

Thanks for your help anyway.
Mike


Note You need to log in before you can comment on or make changes to this bug.