Bug 24525 - Packages built locally depend on "libsafe.so.1.3" but package provides "libsafe.so.1"
Summary: Packages built locally depend on "libsafe.so.1.3" but package provides "libsa...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: libsafe (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-21 23:34 UTC by Bill Crawford
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-21 23:34:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Crawford 2001-01-21 23:34:05 UTC
I'm having problems building packages locally: they end up depending on
"libsafe.so.1.3" but the RPM database only shows libsafe as providing
"libsafe.so.1" so rpm -Uvh ... fails with a dependency problem.

Is this a problem with RPM or with the libsafe package? I'm really not
sure, actually.

Comment 1 Tim Powers 2001-01-22 16:09:32 UTC
The problem is in the libsafe RPM. What I have done to fix kthis is include the
liblink (libsafe.so.1 -> libsafe.so.1.3) in the package itself, instead of
having the link generated automagically when it is loaded. This should make the
problem just "go away".

It's built for the next release and you should be able to download it from
rawhide the next time rawhide is updated.

Tim


Note You need to log in before you can comment on or make changes to this bug.