Bug 245291 - bind-utils are SegFaulting
bind-utils are SegFaulting
Status: CLOSED DUPLICATE of bug 246623
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 03:36 EDT by Steinhauer Juergen
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 18:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core Dump (4.28 KB, application/octet-stream)
2007-06-22 05:02 EDT, Steinhauer Juergen
no flags Details

  None (edit)
Description Steinhauer Juergen 2007-06-22 03:36:36 EDT
Description of problem:
The bind-utils (host, dig, rndc,....) are segfaulting regularly.

Version-Release number of selected component (if applicable):
9.4.0-6

How reproducible:
Simple shell script which is querying "rndc status" every second. 

Actual results:
SegFault. (Occassionally.)

Expected results:
No problems.

Additional info:
The problem first occured on HA systems (heartbeat) where "rndc status" is
called every 2 seconds to check the Bind daemon.
After some investigations the problem could be identified in the PIE
comiler/linker options. Disabling this option solves the problem.
Comment 1 Adam Tkac 2007-06-22 04:21:34 EDT
Interesting. This never occurs to me. I'm going to try reproduce it. It would be
nice if you attach core dump when next segfault occurs. You could run something
like this

#!/bin/bash

ulimit -c unlimited

while [ 1 -eq 1 ]; do
sleep 1;
/usr/sbin/rndc status;
done

Thanks, Adam
Comment 2 Steinhauer Juergen 2007-06-22 05:02:58 EDT
Created attachment 157603 [details]
Core Dump
Comment 3 Adam Tkac 2007-06-22 05:17:23 EDT
Thanks, I'm going to analyze it
Comment 4 Adam Tkac 2007-06-22 05:26:18 EDT
Realy looks like glibc issue. It will be gcc problem but looks more like dynamic
linker problem for me. Backtrace from uploaded core dump

(gdb) bt
#0  0x0059c402 in _start () from /lib/ld-linux.so.2
Cannot access memory at address 0xbfa1e9f0

Reassigning to glibc

Adam
Comment 5 Jakub Jelinek 2007-06-22 09:33:11 EDT
More likely kernel randomization messing up things.
The core file is extremely weird:
info regs
eax            0xffffffea       -22
ecx            0x9ae9f58        162439000
edx            0x9ae9090        162435216
ebx            0x9ae8ee0        162434784
esp            0xbfa1e9f0       0xbfa1e9f0
ebp            0xbfa1eaf8       0xbfa1eaf8
esi            0x9ae6d88        162426248
edi            0xbd3ff4 12402676
eip            0x59c402 0x59c402 <_start>
eflags         0x212    [ AF IF ]
cs             0x73     115
ss             0x7b     123
ds             0x7b     123
es             0xc040007b       -1069547397
fs             0x0      0
gs             0x0      0
but the PT_LOAD segments in core are:
  LOAD           0x001000 0x00a2d000 0x00000000 0x00000 0x05000 R E 0x1000
  LOAD           0x001000 0x00a32000 0x00000000 0x02000 0x02000 RW  0x1000
  LOAD           0x003000 0x00a78000 0x00000000 0x00000 0x19000 R E 0x1000
  LOAD           0x003000 0x00a91000 0x00000000 0x02000 0x02000 RW  0x1000
  LOAD           0x005000 0xbff69000 0x00000000 0x15000 0x15000 RW  0x1000
So, neither $eip nor $esp nor $ebp fall into an mapped region.
I certainly can't reproduce this myself on F7 with x86_64 kernel, nor on
RHEL5 i686, but occasional PIE crashes have been reported already in the
past, e.g. #217614.
Comment 6 Jan Kratochvil 2007-06-26 13:02:42 EDT
Steinhauer Juergen,
as it is unreproducible for me could you please provide some system info by:
cat /proc/version;a=`rpm --qf '%{name}-%{version}-%{release}.%{arch}\n'
-qa|egrep '^(kernel|glibc|bind)'|sort`;echo $a;rpm -V $a
Comment 7 Steinhauer Juergen 2007-06-27 09:08:47 EDT
Linux version 2.6.21-1.3228.fc7 (kojibuilder@xenbuilder2.fedora.redhat.com) (gcc
version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Tue Jun 12 15:37:31 EDT 2007

bind-9.4.1-6.1.fc7.i386 bind-libs-9.4.1-6.1.fc7.i386
bind-utils-9.4.1-6.1.fc7.i386 glibc-2.6-3.i686 glibc-common-2.6-3.i386
kernel-2.6.21-1.3194.fc7.i686 kernel-2.6.21-1.3228.fc7.i686

I've made a VMware installation in which I can also reproduce the problem.
Comment 8 Jakub Jelinek 2007-07-03 18:16:50 EDT

*** This bug has been marked as a duplicate of 246623 ***

Note You need to log in before you can comment on or make changes to this bug.