Bug 245293 - kpowersave can't find pidof
kpowersave can't find pidof
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kpowersave (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 04:06 EDT by Doncho N. Gunchev
Modified: 2008-04-29 17:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.7.3-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 17:00:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The error message screenshot (the error window only). (29.64 KB, image/png)
2008-03-07 19:32 EST, Doncho N. Gunchev
no flags Details

  None (edit)
Description Doncho N. Gunchev 2007-06-22 04:06:26 EDT
Description of problem:
Every now and then (at start, after resume) kpowersave complains that 
it "Could not start 'pidof'. Could not autosuspend the machine.
Please check your installation.".

Version-Release number of selected component (if applicable):
kpowersave-0.7.2-1.fc7

How reproducible:
Almost every time

Steps to Reproduce:
1. install kpowersave, run it in KDE
2. logout
3. login

Additional info:
It also complained about not being able to umount all removable devices a few 
times.
Comment 1 Marcin Wilk 2007-11-04 20:24:03 EST
noticed the same problem... since j'm running non english version the
translation of system massage is like ...."kpowersave is not able to execute/run
pidof, could not autosuspend, Please check suspend settings"....

it cures every time i login the system or change settings in kpowersave...

suspending manually using kpowersave works fine...

---------------------------------------------------------------------
System config:

FC7 KDE3.5.7
kernel 2.6.23.1-10_1.cubbi_tuxonice.fc7 #1 SMP i686 (atrpms)
kpowersave-0.7.3-0.2svn20070828.fc7
pm-utils-0.99.4-3.fc7 (atrpms)
acpid-1.0.4-8.fc7
acpitool-0.4.6-2.fc6
acpi-0.09-2.fc6
wmacpi-2.2-0.1.a1.fc7
hal-0.5.9-8.fc7
dbus-1.0.2-6.fc7

/sbin/pidof
Comment 2 Joshua Covington 2008-02-06 18:22:01 EST
same here with fedora 8, up-to-date as of feb.7, 2008
Comment 3 Rex Dieter 2008-02-06 22:14:03 EST
Cannot confirm, worksforme.
Comment 4 Doncho N. Gunchev 2008-02-24 18:16:46 EST
Looks working here too... No idea when it got fixed, but for a long time I 
don't have this problem.
Comment 5 Doncho N. Gunchev 2008-03-04 20:04:11 EST
Well... it got fixed at some point...
Comment 6 Doncho N. Gunchev 2008-03-07 19:30:39 EST
Sorry, saw this again today... kpowersave-0.7.3-1.fc8.
Comment 7 Doncho N. Gunchev 2008-03-07 19:32:21 EST
Created attachment 297262 [details]
The error message screenshot (the error window only).
Comment 8 Greg Martyn 2008-03-09 15:15:41 EDT
I can confirm this.

Here's the interesting part: /sbin/pidof exists

grep -R pidof /var/log
..doesn't return any results
Comment 9 Rex Dieter 2008-04-07 09:45:39 EDT
ok, looks like this was fixed only in rawhide, in build kpowersave-0.7.3-3.

Looks like we need to issue an update for f7/f8.
Comment 10 Fedora Update System 2008-04-07 09:47:50 EDT
kpowersave-0.7.3-3.fc8 has been submitted as an update for Fedora 8
Comment 11 Fedora Update System 2008-04-09 01:17:18 EDT
kpowersave-0.7.3-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kpowersave'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2959
Comment 12 Fedora Update System 2008-04-29 17:00:37 EDT
kpowersave-0.7.3-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.