Bug 2453 - XFree86 depends on xbanner ?!?!?
XFree86 depends on xbanner ?!?!?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-30 18:41 EDT by monnier+lists/redhat/bugs
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-10 19:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description monnier+lists/redhat/bugs 1999-04-30 18:41:17 EDT
Why does XFree86 depend on xbanner ??
Comment 1 rmc 1999-05-03 15:19:59 EDT
Because xbanner is used by xdm, I guess.
maybe xdm should be put into a separate package?
Comment 2 Chris Siebenmann 1999-05-04 18:48:59 EDT
I think it would be good to split xdm config files and the like
off from the main X package, so that people can still install the
base X stuff on a small system without having to pull in all the
stuff that's just there to make it look pretty and isn't necessary
for functionality.

 Better would be a general revision in packaging to split 'pretty
config files' away from everything else. For things like XDM, I'd
suggest that there be a 'basic' set of config files in the core
package, and another set of optional pretty config files. If the
pretty config files are installed the basic ones can notice and
include them; only the pretty config files would require things
like xbanner et al.

 This may well be too complicated for RedHat to find worthwhile.
Comment 3 David Lawrence 1999-05-10 19:44:59 EDT
Thank you for your suggestion. It will be considered for the next
release of Red Hat Linux.

Note You need to log in before you can comment on or make changes to this bug.